Forum: Ruby ruby install conflict and ruby-dbi-all on debian 3.1

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
bill (Guest)
on 2006-01-07 10:08
(Received via mailing list)
Hi there,

I am running debian 3.1(sarge, I think).
I need to be able to connect to mysql, Postgres & Oracle.
I can connect to postgres & Mysql but Oracle (to a remote host) is
proving a pain.

Following problems and looking on forums I have done the following ruby
install.

    apt-get install ruby ruby1.8 ruby1.8-examples libyaml-ruby1.8
libdbm-ruby1.8 libopenssl-ruby1.8
        liberb-ruby1.8 libsyslog-ruby1.8 libtest-unit-ruby1.8
ruby1.8-dev libruby1.8 libiconv-ruby1.8

    installed rubygems

    apt-get install libdbd-pg-ruby

   apt-get install libdbd-mysql-ruby

   ruby-dbi-all
     This said it could not find sqlite library !
     So I did:
           ruby setup.rb config --with=dbi,dbd_oracle

However, there appers to a conflict:

   ls -l /usr/lib/ruby/1.8/DBD
total 8
drwxr-xr-x  2 root root 4096 2006-01-05 16:15 Mysql
drwxr-xr-x  2 root root 4096 2006-01-05 16:15 Pg

   ls -l /usr/local/lib/site_ruby/1.8/DBD
total 4
drwxr-sr-x  2 root staff 4096 2006-01-05 17:34 Oracle

Why are they in different places ?
I am assuming this is my problem.

I have tried commands like:
   ruby setup.rb config --with=dbi,dbd_oracle
--bin-dir=/usr/lib/ruby/1.8
but these do not appear to have worked.

Any help appreciated.
This topic is locked and can not be replied to.