Forum: Rails Engines rake plugindoc returns error - any idea what the problem is

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
alex nesbitt (Guest)
on 2006-01-05 08:50
(Received via mailing list)
I'm trying to make docs and when I run rake plugindoc I get

rdoc -o doc/plugins/engines --title 'Engines Plugin Documentation'
--line-number
s --inline-source -T html --main 'vendor/plugins/engines/README'
vendor/plugins/
engines/lib/action_mailer_extensions.rb
vendor/plugins/engines/lib/action_view_e
xtensions.rb vendor/plugins/engines/lib/dependencies_extensions.rb
vendor/plugin
s/engines/lib/engines.rb
vendor/plugins/engines/lib/migration_extensions.rb
vend
or/plugins/engines/lib/ruby_extensions.rb
vendor/plugins/engines/lib/testing_ext
ensions.rb vendor/plugins/engines/README
rake aborted!
You have a nil object when you didn't expect it!
The error occured while evaluating nil.exitstatus

any ideas what the problem might be?

Thanks

Alex
Kevin O. (Guest)
on 2006-01-05 18:23
alex nesbitt wrote:
> I'm trying to make docs and when I run rake plugindoc I get
>
> rdoc -o doc/plugins/engines --title 'Engines Plugin Documentation'
> --line-number
> s --inline-source -T html --main 'vendor/plugins/engines/README'
> vendor/plugins/
> engines/lib/action_mailer_extensions.rb
> vendor/plugins/engines/lib/action_view_e
> xtensions.rb vendor/plugins/engines/lib/dependencies_extensions.rb
> vendor/plugin
> s/engines/lib/engines.rb
> vendor/plugins/engines/lib/migration_extensions.rb
> vend
> or/plugins/engines/lib/ruby_extensions.rb
> vendor/plugins/engines/lib/testing_ext
> ensions.rb vendor/plugins/engines/README
> rake aborted!
> You have a nil object when you didn't expect it!
> The error occured while evaluating nil.exitstatus
>
> any ideas what the problem might be?
>
> Thanks
>
> Alex

Are you using 'InstantRails'?

I had a similar problem with "rake appdoc" that went away when I
upgraded to the most recent InstantRails release.
This topic is locked and can not be replied to.