Forum: Ruby on Rails Newbie question abour Rake

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jeff C. (Guest)
on 2006-01-04 08:39
I'm learning about rake, and have what is probably a silly question.
When I run rake from my rails app's top directory, what rakefile is it
really running?

I have rails 1.0, and in my top-level directory there is a small file
called "Rakefile", which basically just includes a few other files:

require 'rake'
require 'rake/testtask'
require 'rake/rdoctask'
require 'tasks/rails'

If this is indeed the file that's being used when I run rake without any
parameters, then the tasks must be defined in these other files... but I
can't find these files on my machine.  I've looked in my rails app's
subfolders, as well as under the directory where the Rails 1.0.0 gem is
installed on my box, to no avail (though I did find a rather large
Rakefile there...?)

Can anyone shed a little light or just get me started in the right
direction?

Thanks!
Jeff
Norman T. (Guest)
on 2006-01-04 13:36
(Received via mailing list)
Am Mittwoch, den 04.01.2006, 07:39 +0100 schrieb Jeff C.:
> require 'tasks/rails'
>
> Thanks!
> Jeff

On my Debian machine i found the file under

/usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/tasks/rails.rb
This topic is locked and can not be replied to.