Forum: Ruby Installing ruby-libs-1.8.4-0.4.preview2.i386.rpm on FC4?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Philip R. (Guest)
on 2006-01-02 06:31
(Received via mailing list)
People,

Has anyone been able to install these preview RPMs?

I get:

rpm -ivh ruby-libs-1.8.4-0.4.preview2.i386.rpm

error: Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by
ruby-libs-1.8.4-0.4.preview2.i386
        libcrypto.so.6 is needed by ruby-libs-1.8.4-0.4.preview2.i386
        libssl.so.6 is needed by ruby-libs-1.8.4-0.4.preview2.i386

I don't know if upgrading glibc-2.3.5 to glibc-2.3.90 would help but I
am worried that it would break lots of things . .

I have been able to build 1.8.4 from source but I need to install:

	ruby-devel-1.8.4-0.4.preview2.i386.rpm

to get Rails working with PostgreSQL?

Thanks,

Phil.
--
Philip R.

Pricom Pty Limited  (ACN 003 252 275  ABN 91 003 252 275)
GPO Box 3411
Sydney NSW      2001
Australia
Mobile:  +61:(0)411-185-652
Fax:     +61:(0)2-8221-9599
E-mail:  removed_email_address@domain.invalid
Oliver A. (Guest)
on 2006-01-02 12:54
(Received via mailing list)
Hi,

if you actually want to use these RPMs, I would fetch the SRPM
(source RPM) and compile it on my own. The path you want to stride, is
the path to FC5 test 1 (or whatever is current). ANd this path you don't
want to walk at the moment.

I am not sure, why you need 1.8.4 for a Rails with PostgreSQL, cause I
don't use PostgreSQL. But my Rails setup works fine so far with the
1.8.3 RPM from FC4.

But let me repeat it. If you want to use the preview RPM, then go and
fetch the SRPM. Compile it on your system and use the result.

Best regards,
Oliver
unknown (Guest)
on 2006-01-02 20:31
(Received via mailing list)
I make a rpm of 1.8.4 for ... myself on FC4 :-)
So if you want try it :
   http://people.vnoss.org/~vnpenguin/pub/rpm/ruby/
Oliver A. (Guest)
on 2006-01-06 09:22
(Received via mailing list)
Just for the record, today 1.8.4 has been pushed back from FC5 to FC4. I
got this information as an answer to a Bugreport I opened. It is also
already available as an update.

Best regards,
Oliver
This topic is locked and can not be replied to.