Forum: Ruby on Rails What does this error mean when using scaffold?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Frank R. (Guest)
on 2005-12-31 05:29
(Received via mailing list)
Last login: Fri Dec 30 15:34:43 on ttyp1
source /private/var/tmp/folders.501/TemporaryItems/Locomotive.
1135999534.992790-16807
Welcome to Darwin!
frank-roccos-powerbook58:~ farocco$ source /private/var/tmp/folders.
501/TemporaryItems/Locomotive.1135999534.992790-16807
frank-roccos-powerbook58:~/Documents/receipts farocco$ script/
generate scaffold receipt receipt
./script/../config/../config/environment.rb:63: undefined method
`config' for LoginEngine:Module (NoMethodError)
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require__'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/gems/1.8/gems/
activesupport-1.2.5/lib/active_support/dependencies.rb:214:in `require'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/gems/1.8/gems/
rails-1.0.0/lib/commands/generate.rb:1
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require__'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/gems/1.8/gems/
activesupport-1.2.5/lib/active_support/dependencies.rb:214:in `require'
         from script/generate:3

Thanks
Frank
Joe Van D. (Guest)
on 2005-12-31 13:42
(Received via mailing list)
On 12/30/05, Frank R. <removed_email_address@domain.invalid> wrote:
> Last login: Fri Dec 30 15:34:43 on ttyp1
> source /private/var/tmp/folders.501/TemporaryItems/Locomotive.
> 1135999534.992790-16807
> Welcome to Darwin!
> frank-roccos-powerbook58:~ farocco$ source /private/var/tmp/folders.
> 501/TemporaryItems/Locomotive.1135999534.992790-16807
> frank-roccos-powerbook58:~/Documents/receipts farocco$ script/
> generate scaffold receipt receipt
> ./script/../config/../config/environment.rb:63: undefined method
> `config' for LoginEngine:Module (NoMethodError)

Looks to be a problem with the LoginEngine.  Remove it or update it.
Frank R. (Guest)
on 2005-12-31 15:30
(Received via mailing list)
ok, I removed it from my app.
Now I get:

Last login: Fri Dec 30 22:28:51 on ttyp2
Welcome to Darwin!
frank-roccos-powerbook58:~ farocco$ source /private/var/tmp/folders.
501/TemporaryItems/Locomotive.1136035608.399420-16807
frank-roccos-powerbook58:~/Documents/receipts farocco$ script/
generate scaffold receipt receipt
./script/../config/../config/environment.rb:63: undefined method
`config' for LoginEngine:Module (NoMethodError)
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require__'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/gems/1.8/gems/
activesupport-1.2.5/lib/active_support/dependencies.rb:214:in `require'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/gems/1.8/gems/
rails-1.0.0/lib/commands/generate.rb:1
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require__'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:21:in `require'
         from /Users/farocco/Desktop/Locomotive/Bundles/rails-1.0.0-
min.bundle/Contents/Resources/ports/lib/ruby/gems/1.8/gems/
activesupport-1.2.5/lib/active_support/dependencies.rb:214:in `require'
         from script/generate:3
Ryan R. (Guest)
on 2005-12-31 15:37
(Received via mailing list)
On 12/31/05, Frank R. <removed_email_address@domain.invalid> wrote:
> ok, I removed it from my app.
> Now I get:
>
> Last login: Fri Dec 30 22:28:51 on ttyp2
> Welcome to Darwin!
> frank-roccos-powerbook58:~ farocco$ source /private/var/tmp/folders.
> 501/TemporaryItems/Locomotive.1136035608.399420-16807
> frank-roccos-powerbook58:~/Documents/receipts farocco$ script/
> generate scaffold receipt receipt

> ./script/../config/../config/environment.rb:63: undefined method
> `config' for LoginEngine:Module (NoMethodError)

There still seem to be some remnants of the LoginEngine floating
around in there somehow...

> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


-r

--
Ryan R.
http://www.rockefeller.edu -- Bacterial Pathogenesis and Immunology
http://www.worldmartial.com -- Black Belt Instructor
http://locomotive.sourceforge.net -- Self contained one-click Rails for
Mac OS X
Frank R. (Guest)
on 2005-12-31 17:49
(Received via mailing list)
ok,

I generated a new app nad it seems to be ok.
I am attempting to fix the old app by removing loginEngine.

Thanks
Frank
Joe Van D. (Guest)
on 2006-01-01 19:54
(Received via mailing list)
On 12/31/05, Frank R. <removed_email_address@domain.invalid> wrote:
> `config' for LoginEngine:Module (NoMethodError)
Look at line 63 in config/environment.rb.  Remove the LoginEngine stuff.
James A. (Guest)
on 2006-01-01 22:19
(Received via mailing list)
Getting back to the original problem, it's because the 'config' method
couldn't be found. Did you remember to install the Engines plugin
itself? (ruby script/plugin install engines) This is the plugin that
defines the 'config' method.

- james
This topic is locked and can not be replied to.