Forum: Ruby on Rails RE: Rails using DB2

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
David B. (Guest)
on 2005-12-30 21:56
(Received via mailing list)
That was the first page I went to.  Will go back and give it another
try.  I guess we need to compile the C the adapter our selves.

Thanks for responding.
John G. (Guest)
on 2006-01-01 19:33
(Received via mailing list)
David B. <DavidB@...> writes:

> On 12/30/05, David B. <DavidB@...> wrote:
> >
> > Hello,
> >
> > I have been trying to connect a Rails application to DB2 database.
> Based on
> > information found on the web it doesn't seem to be possible.  Can some
> > confirm the state of DB2 support with Rails?

Hi David,

 As of right now DB2 doesn't work. Or at least doesn't work without some
hacking and compromises.
 The good news is it's being worked on and great progress has been made.
There are a few people who
 have run into these problems with DB2 but no one ever communicated that
information to the Rails
 guys, or Maik Schmidt (the DB2 Adapter author) until I started whining
about it! :-)

Larry K. (Guest)
on 2006-02-10 00:56
(Received via mailing list)
Is there an update to the DB2 support options?  There's a DB2 database
I'd like to talk to.


On 1/1/06, John G. <removed_email_address@domain.invalid> wrote:
> > Based on
> information to the Rails
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid

Best Regards,
"Work, work, work...there is no satisfactory alternative."
            --- E.Taft Benson
Patrick H. (Guest)
on 2006-02-10 01:08
(Received via mailing list)
On 2/9/06, Larry K. <removed_email_address@domain.invalid> wrote:
> Is there an update to the DB2 support options?

DB2 has worked for me. There are some issues building under Win32 and
regardless you need to have installed db2cli interface (see the dbi
project on rubyforge). I also had issues until I switched to edge

The last remaining issue is the current adapter (as of a week or two
ago), was a little crude in handling different types so it is
important to do:

row = Table.find 1

and not

row = Table.find '1'

Good luck

p.s. check my blog for some information concerning building db2cli
under win32 --
This topic is locked and can not be replied to.