Forum: Ruby on Rails Can't quite get fcgid working

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Gregory S. (Guest)
on 2005-12-28 22:02
(Received via mailing list)
I'm having trouble with running my app under fcgid. I am getting errors
in
my Apache log. It seems that it is choking on the gems replacement for
require. The relevant lines from /var/log/apache2/error.log:

/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- initializer (LoadError)
	from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
	from /home/gss/work/ruby/bookmarkfeeds/public/../config/boot.rb:16
	from
/home/gss/work/ruby/bookmarkfeeds/public/../config/environment.rb:8
	from /home/gss/work/ruby/bookmarkfeeds/public/dispatch.fcgi:21
[Wed Dec 28 14:52:29 2005] [error] [client 192.168.1.1] Premature end of
script headers: dispatch.fcgi
[Wed Dec 28 14:52:35 2005] [notice] mod_fcgid: process
/home/gss/work/ruby/bookmarkfeeds/public/dispatch.fcgi(17965)
exit(communication error), terminated by calling exit(), return code: 1

Configuration notes: ruby 1.8.4, latest rails via rubygems, Apache2,
Debian. I am trying to run as a non-vhost per
http://wiki.rubyonrails.com/rails/pages/Non+VHost+...

Any thoughts?

--Greg
Gregory S. (Guest)
on 2005-12-29 04:16
(Received via mailing list)
It turns out that the GEM_HOME environment variable, which I need since
I
installed gem in /usr/local, was being removed from the environment even
though it is set in /etc/profile. I added the following line at the
beginning of my config/environment.rb and all is well now:

ENV['GEM_HOME'] = '/usr/local/lib/site_ruby/gems'

--Greg

On Wed, Dec 28, 2005 at 03:01:07PM -0500, Gregory S. wrote:
} I'm having trouble with running my app under fcgid. I am getting
errors in
} my Apache log. It seems that it is choking on the gems replacement for
} require. The relevant lines from /var/log/apache2/error.log:
}
} /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- initializer (LoadError)
} 	from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
} 	from /home/gss/work/ruby/bookmarkfeeds/public/../config/boot.rb:16
} 	from
/home/gss/work/ruby/bookmarkfeeds/public/../config/environment.rb:8
} 	from /home/gss/work/ruby/bookmarkfeeds/public/dispatch.fcgi:21
} [Wed Dec 28 14:52:29 2005] [error] [client 192.168.1.1] Premature end
of script headers: dispatch.fcgi
} [Wed Dec 28 14:52:35 2005] [notice] mod_fcgid: process
/home/gss/work/ruby/bookmarkfeeds/public/dispatch.fcgi(17965)
exit(communication error), terminated by calling exit(), return code: 1
}
} Configuration notes: ruby 1.8.4, latest rails via rubygems, Apache2,
} Debian. I am trying to run as a non-vhost per
} http://wiki.rubyonrails.com/rails/pages/Non+VHost+...
}
} Any thoughts?
}
} --Greg
}
} _______________________________________________
} Rails mailing list
} removed_email_address@domain.invalid
} http://lists.rubyonrails.org/mailman/listinfo/rails
}
This topic is locked and can not be replied to.