Forum: Ruby Rails didn't install correctly

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Steve L. (Guest)
on 2005-12-28 17:25
(Received via mailing list)
Hi all,

I already sent this to the Rails list, but I figure someone here might
know
how to troubleshoot this.

Apparently rails didn't install correctly on my Mandrake 10.0 system.
=================================
[slitt@mydesk work]$ rails demo
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:204:in
`report_activate_error':
Could not find RubyGem rails (> 0) (Gem::LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:141:in
`activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
`require_gem_with_options'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:31:in
`require_gem'
        from /usr/bin/rails:17
[slitt@mydesk work]$
=================================

What is "RubyGem rails (> 0)"?

I installed rails with this command as root:

gem install rails --include-dependencies

It errored out (can't remember what it didn't find) so I ran it again
and it
said it installed successfully.

My Mandrake 10.0 came with Ruby 1.8.1 which is insufficient for rails,
so I
installed ruby 1.8.4 in /usr/local/bin, and then renamed the ruby in
/usr/bin
to ruby.1.8.1, and then set up a symlink from /usr/bin/ruby
to /usr/local/bin/ruby. At that point, running Ruby brought up 1.8.4.

I have no idea what the error message meant by "RubyGem rails (> 0)".
Can
anyone give me some hints on how to troubleshoot this?

Thanks

SteveT

Steve L.
http://www.troubleshooters.com
removed_email_address@domain.invalid
Jon B. (Guest)
on 2005-12-28 20:04
(Received via mailing list)
If I can remember correctly I had to set env variable RUBY_LIB to it's
corresponding path ... /usr/local/lib/ruby/site_ruby/1.8/ in order to
get gems and rails to work ... may want to try that.
Steve L. (Guest)
on 2005-12-28 21:04
(Received via mailing list)
Hi all,

What I did was reinstalled, but this time without the
--include-dependencies.

gem install rails

This meant that for each dependency, I had to say yes. The install
appeared to
go through cleanly. I then did rails demo, and it did the right thing,
and
after this:

cd /home/slitt/work/demo
ruby script/server

I was able to pull up a rails generated page on http://localhost:3000.

I have NO IDEA why installing without the --include-dependencies would
have
made the problem go away, or even whether the thing that fixed it was
just
doing one more install of any kind. What I do know is I found out about
running without --include-dependencies after google searching the error
message, and that email thread suggested just gem install rails.

If anyone else asks about a "Could not find RubyGem rails" error, please
tell
them to try not using --include-dependencies, and please tell me what
happened, as I'd like to find the true root cause of this problem.

Thanks

SteveT
This topic is locked and can not be replied to.