Forum: Ruby on Rails trouble getting started (on a mac)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Aaron Ross Powell (Guest)
on 2005-12-27 23:13
(Received via mailing list)
Hi-

I picked up "Agile Web D. with Rails" a little while ago
after getting excited by all the hubbub surrounding the 1.0 release.
I started working my way through it and have run into a few problems
that I'd love to know if anyone has any suggestions about.

I'm using my Powerbook, running OS X 10.4.3.  I installed the latest
version of Locomotive and downloaded the Rails 1.0 Max bundle for it
(which is what I used when creating the applications for the
tutorial).

My first problem is the database.  I installed MySQL 5.0 and managed
to get it going just fine.  I was able to get a test Rails app to
connect to it.  But, for some reason, it's now stopped working.  Rails
tells me that authorization was denied and that (PASSWORD: No).  I've
tried editing the settings in the database.yml file both to use and
not use the password and both throw the same error.  Using CocoaMySQL,
I can connect just fine (with the password, connecting to localhost as
user root), add databases, tables, etc.

The second problem is a weird one (I think).  Back when the database
was working (and it still does it now, too), when I run "ruby
script/generate scaffold Product Admin" in the Agile book's depot
tutorial, instead of generating a controller and view for "admin"
(which is what the book says should happen), it makes ones called
"products".  They work like they're supposed to (or, at least, they
did before the database stopped functioning) but only at /products
instead of /admin.  I contacted the book's author and he said the
problem was that I was running an old version of Rails and that I
needed to upgrade to 1.0.  I did that (getting the 1.0 bundle for
Locomotive) and, after checking that it is in fact 1.0, ran the script
again with the same result.  Is there something wrong with that
command?

I appreciate any help I can get on these issues.  Rails looks like a
dream come true for someone who's spent most of his web development
time hacking away at small PHP apps.  Now I just need to get it
working enough that I can actually start playing with it.

Thanks,

Aaron Powell
This topic is locked and can not be replied to.