Forum: Ruby on Rails confused about ruby fast C bindings

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Shelby W. (Guest)
on 2005-12-27 01:12
(Received via mailing list)
I am confused about ruby fast C bindings.  Does the command:

gem install mysql

install these?

Is this page:
http://www.tmtm.org/en/mysql/ruby/
the home page for these bindings?  If so, it gives no instructions about
installing them with using gem.

Wondering if this is all the same???

Thanks for any help...
Shelby
Ezra Z. (Guest)
on 2005-12-27 01:45
(Received via mailing list)
On Dec 26, 2005, at 3:10 PM, Shelby W. wrote:

>
> Wondering if this is all the same???
>
> Thanks for any help...
> Shelby
>
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails

Yes they are the same thing. What platform are you trying to install
them on? If you are on linux or osx try this command:

$ which mysql_config

If that returns the location then you can install the bindings like
this:

$ sudo gem install mysql -- --with-mysql-config

Or you can download the tar.gz from the site you mentioned and
install them that way. The net result is the same though. If you are
on windows or which mysql_config turns up nothing, you should read
the readme in the tar.gz file and move on to one the recommendations
there.

Cheers-
-Ezra Z.
WebMaster
Yakima Herald-Republic Newspaper
removed_email_address@domain.invalid
509-577-7732
Shelby W. (Guest)
on 2005-12-27 02:21
(Received via mailing list)
Ezra suggested:

>
> $ sudo gem install mysql -- --with-mysql-config
>

This worked on my OS X 10.3.9 box.  excellent...

I had tried:
sudo gem install mysql -- --include=/usr/local/lib
as the comments at the top of the database.yml file of a newly created
rails
1.0 app tells me.  But that didn't work...

Thanks, Ezra!
Shelby
This topic is locked and can not be replied to.