Forum: Ruby Dumb question concerning ruby 1.8.2 and 1.8.3

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Oliver A. (Guest)
on 2005-12-19 20:24
(Received via mailing list)
Hi,

I will use the holidays to do my first real steps with Rails. No toying
around but actually developing an application that is planned to be used
in an production environment early next year. Now I have read several
times that 1.8.3 seems to have some bugs, that are causing people to
stick too 1.8.2. Sadly, I don't come up with the right google mantra to
find anything helpful concerning this question. So, I like to ask here
if someone can give me some pointers concering this. Or otherwise
disperse the bad feeling I have at the moment.

So far, I haven't discovered any bug myself and I already use 1.8.3 for
some production code. Mostly scripts for workflow jobs so far. May be
using Rails it is more an issue.

Hopefully, I am not wasting your time and bandwidth, cause I could have
found all the information I need in an obvious location. :)

Best regards,
Oliver
James G. (Guest)
on 2005-12-19 20:30
(Received via mailing list)
On Dec 19, 2005, at 12:22 PM, Oliver A. wrote:

> So, I like to ask here if someone can give me some pointers
> concering this. Or otherwise disperse the bad feeling I have at the
> moment.

You're probably fine.  1.8.3 originally broke Rails (and Rake, I
believe) but the latest versions work fine.

The biggest outstanding 1.8.3 bug is the you can't effectively build
RubyGems with it.  Just be aware of that.

1.8.4 is due in less than a week now as well, just FYI.

James Edward G. II
gabriele renzi (Guest)
on 2005-12-19 21:09
(Received via mailing list)
James Edward G. II ha scritto:

> The biggest outstanding 1.8.3 bug is the you can't effectively build
> RubyGems with it.  Just be aware of that.

was'nt the problem about using gems made with ruby-X with ruby-Y ?
James G. (Guest)
on 2005-12-19 21:27
(Received via mailing list)
On Dec 19, 2005, at 1:07 PM, gabriele renzi wrote:

> James Edward G. II ha scritto:
>
>> The biggest outstanding 1.8.3 bug is the you can't effectively
>> build  RubyGems with it.  Just be aware of that.
>
> was'nt the problem about using gems made with ruby-X with ruby-Y ?

Pretty much, yes.  But since RubyForge is currently running < 1.8.3,
you have the consider that it's not possible to distribute anything
made with the newer versions (through them).

Just to be clear, this is a YAML issue (not RubyGems).

James Edward G. II
Oliver A. (Guest)
on 2005-12-19 22:13
(Received via mailing list)
Many thanks for the information. This gives me a much better feeling for
the things ahead. :)

Best regards,
Oliver

James Edward G. II schrieb:
Steve L. (Guest)
on 2005-12-20 16:06
(Received via mailing list)
On Monday 19 December 2005 01:27 pm, James Edward G. II wrote:
>
> 1.8.4 is due in less than a week now as well, just FYI.

Do you think 1.8.4 will be less problematic?

Steve L.
http://www.troubleshooters.com
removed_email_address@domain.invalid
James G. (Guest)
on 2005-12-20 16:18
(Received via mailing list)
On Dec 20, 2005, at 8:04 AM, Steve L. wrote:

> Do you think 1.8.4 will be less problematic?

Yes, the patch was applied last night to fix the YAML issue.

James Edward G. II
This topic is locked and can not be replied to.