Forum: Ruby on Rails OpenBSD 3.8, Apache 1.3, FastCGI, Chroot

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Michael S. (Guest)
on 2005-12-18 02:26
(Received via mailing list)
Okay, well the OpenBSD install/chroot guide is a good starting point....

Anyhow, Can someone shed some light on these particular error messages?

[Sat Dec 17 18:42:34 2005] [notice] Initializing etag from
[Sat Dec 17 18:42:34 2005] [notice] chrooted in /var/www
[Sat Dec 17 18:42:34 2005] [notice] changed to uid 1, gid 1
[Sat Dec 17 18:42:34 2005] [notice] Apache/1.3.29 (Unix)
mod_fastcgi/2.4.2 mod_ssl/2.8.16 OpenSSL/0.9.7g configured -
- resuming normal operations
[Sat Dec 17 18:42:34 2005] [notice] Accept mutex: sysvsem (Default:
[Sat Dec 17 23:42:34 2005] [notice] FastCGI: process manager chrooted
in /var/www
[Sat Dec 17 23:42:34 2005] [notice] FastCGI: process manager
initialized (pid 23865)
[Sat Dec 17 23:42:34 2005] [warn] FastCGI: server
"/var/www/users/mike/rails/public/dispatch.fcgi" started (pid 3400)
FastCGI: can't start server
"/var/www/users/mike/rails/public/dispatch.fcgi" (pid 3400), chdir()
failed: No such file
 or directory

my httpd.conf

LoadModule fastcgi_module     usr/lib/apache/modules/
<IfModule mod_fastcgi.c>
  FastCgiIpcDir /var/www/tmp/fcgi_ipc
  FastCgiServer /var/www/users/mike/rails/public//dispatch.fcgi \
    -initial-env RAILS_ENV=development \
    -idle-timeout 60
LoadModule rewrite_module usr/lib/apache/modules/

<VirtualHost *:80>
   DocumentRoot /var/www/users/mike/rails/public/
   ErrorLog /var/www/users/mike/rails/log/server.log

   <Directory /users/mike/rails/public/>
      Options ExecCGI FollowSymLinks
      AddHandler cgi-script .cgi
      AllowOverride all
      Order allow,deny
      Allow from all

OpenBSD 3.8-stable  Apache 1.3, FastCGI, Chroot

I do see the welcome to rails page .. but I get the infamous ..
"APPLICATION ERROR, Rails app failed to start properly"


This topic is locked and can not be replied to.