Forum: Ruby Simply a bug ?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Kane (Guest)
on 2005-12-18 00:51
Hello,

I've a problem under windows xp, someone will told "of course", but in
this case i didn't think it's only windows.
Bref, on IRB all characters "[ | {" and also all characters which use
the ALTGR key under a french keyboard are unusable.

Someone have also this problem ? Someone knows how fix it ?
Damphyr (Guest)
on 2005-12-18 02:02
(Received via mailing list)
Kane wrote:
> Hello,
>
> I've a problem under windows xp, someone will told "of course", but in
> this case i didn't think it's only windows.
> Bref, on IRB all characters "[ | {" and also all characters which use
> the ALTGR key under a french keyboard are unusable.
>
> Someone have also this problem ? Someone knows how fix it ?
>
Yeap, it happens with german and spanish keyboard layouts as well and is
one of the reasons I don't use irb much.
I work around it by switching to a US layout, but it is a PITA.
Just confirming, can't help much.
V.-

--
http://www.braveworld.net/riva
gabriele renzi (Guest)
on 2005-12-18 03:38
(Received via mailing list)
Kane ha scritto:
> Hello,
>
> I've a problem under windows xp, someone will told "of course", but in
> this case i didn't think it's only windows.
> Bref, on IRB all characters "[ | {" and also all characters which use
> the ALTGR key under a french keyboard are unusable.
>
> Someone have also this problem ? Someone knows how fix it ?
>

look in the archives for problems with irb and readline on win32,
basically you need to set up a proper .inputrc file or run irb with
--noreadline.
Sorry I don't have some urls at hand.
Kane (Guest)
on 2005-12-18 05:12
gabriele renzi wrote:
> look in the archives for problems with irb and readline on win32,
> basically you need to set up a proper .inputrc file or run irb with
> --noreadline.
> Sorry I don't have some urls at hand.

Really, --noreadline fix the problerm. It's stange but its walk.

Thanks !
Lionel (Guest)
on 2006-01-03 15:32
Kane wrote:
> gabriele renzi wrote:
>> look in the archives for problems with irb and readline on win32,
>> basically you need to set up a proper .inputrc file or run irb with
>> --noreadline.
>> Sorry I don't have some urls at hand.
>
> Really, --noreadline fix the problerm. It's stange but its walk.
>
> Thanks !

Hi, here is the solution (at least for french keyboards) :

1. create a file called .inputrc containing :
"\M-[": "["
"\M-]": "]"
"\M-{": "{"
"\M-}": "}"
"\M-\\": "\\"
"\M-|": "|"
"\M-@": "@"
"\M-~": "~"

I personally put this file at c:\Documents and Settings\Lionel\.inputrc

2. set an environment variable INPUTRC pointing to the full path of
.inputrc. In my case :

INPUTRC=%HOMEPATH%\.inputrc

You can access to the environment variables under Windows XP in the
Advanced tab of the System control panel. You can also declare it for
your console session running by typing
SET INPUTRC=%HOMEPATH%\.inputrc

Then, readline behaves correctly and accepts these important characters.

Cheers
This topic is locked and can not be replied to.