Forum: Ruby Why would Webrick use 0.0.0.0:3000 instead of 127.0.0.1:3000

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Curt H. (Guest)
on 2005-12-17 20:21
(Received via mailing list)
Someone working through my Rolling with Ruby on Rails tutorial ran into
this. Does anyone know what could cause this? I pasted the text of his
post
below.

Curt

I am using Instant Rails which comes with Rails 1.0, WEBrick 1.3.1 and
Ruby
1.8.2 and I ran the WEBrick server and it starts on http://0.0.0.0:3000
and
not http://127.0.0.1:3000. However, when I tried to connect to
http://0.0.0.0:3000 using my browser, a dialog pops up telling me that
"the
connection was refused". Any suggestions on how to solve this problem?.
olof sivertsson (Guest)
on 2005-12-18 17:52
(Received via mailing list)
netstat and similar utilities will list the address as 0.0.0.0 when your
application listens for connections on _any_ network interface. 0.0.0.0
is
not a real address so you can't connect to it, but you should be able to
connect to 127.0.0.1 and any other IPs that you have assigned to network
interfaces.

Perhaps better explanation:
http://support.microsoft.com/default.aspx?scid=kb;...

Cheers,
Olof
This topic is locked and can not be replied to.