Forum: Ruby on Rails Rails 1.0 & RJS Templates

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jason (Guest)
on 2005-12-15 03:01
Hello all,

I just successfully updated my dev env to Rails 1.0. I then wanted to
get .rjs templates working and followed Cody's instructions at
http://www.codyfauser.com/articles/2005/12/02/rail...
. However, when I try to run 'rake test' I get the following error:

(in
/Users/jason/projects/workarea/biolexis/trunk/rails/vendor/plugins/javascript_generator_templates)
/opt/local/bin/ruby -Ilib:lib
"/opt/local/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb"
"test/controller/new_render_test.rb"
./test/controller/../abstract_unit.rb:10:in `require': No such file to
load -- action_controller (LoadError)
        from ./test/controller/../abstract_unit.rb:10
        from ./test/controller/new_render_test.rb:1:in `require'
        from ./test/controller/new_render_test.rb:1
        from
/opt/local/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5:in
`load'
        from
/opt/local/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5
        from
/opt/local/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5:in
`each'
        from
/opt/local/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5
rake aborted!
Command failed with status (1): [/opt/local/bin/ruby -Ilib:lib
"/opt/local/...]


I have Ruby and Gems installed via Darwinports and my environment (even
w/lighttpd) works fine. However, it seems like the above is not able to
find the action_controller file(s), which are clearly available and
found by my app.

Anyone have any experiences with something similar to this and know of a
possible solution? I'm trying to figure out if there's something I
forgot to set somewhere, but am drawing blanks. One thing I did do way
symlink my /usr/bin/ruby -> /opt/local/bin/ruby so I wouldn't get
further problems when I upgraded any of the Rails libs.

Thanks,

- jason
David Heinemeier H. (Guest)
on 2005-12-15 06:07
(Received via mailing list)
> I just successfully updated my dev env to Rails 1.0. I then wanted to
> get .rjs templates working and followed Cody's instructions at
> http://www.codyfauser.com/articles/2005/12/02/rail...
> . However, when I try to run 'rake test' I get the following error:

RJS is not a 1.0 feature. It's scheduled for 1.1. You can do "rake
freeze_edge" if you want to try it out (along with the rest of the
development version of Rails).
--
David Heinemeier H.
http://www.loudthinking.com -- Broadcasting Brain
http://www.basecamphq.com   -- Online project management
http://www.backpackit.com   -- Personal information manager
http://www.rubyonrails.com  -- Web-application framework
Cody F. (Guest)
on 2005-12-15 16:48
(Received via mailing list)
Jason,

As David mentioned, the best way to run RJS is to put your project on
edge Rails.  You can follow the directions at
http://www.codyfauser.com/articles/2005/11/20/rail... to
help walk you through the process.


Cody


On 12/14/05, David Heinemeier H. <removed_email_address@domain.invalid>
wrote:
> http://www.loudthinking.com -- Broadcasting Brain
> http://www.basecamphq.com   -- Online project management
> http://www.backpackit.com   -- Personal information manager
> http://www.rubyonrails.com  -- Web-application framework
> _______________________________________________
> Rails mailing list
> removed_email_address@domain.invalid
> http://lists.rubyonrails.org/mailman/listinfo/rails
>


--
http://www.codyfauser.com
This topic is locked and can not be replied to.