Forum: Ruby on Rails Webrick is being info on a brand new project

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Pat M. (Guest)
on 2005-12-12 05:42
(Received via mailing list)
I created a project, made a migration, generated scaffolding...start
up webrick and I get nothing.  To simplify things, I just started
another project and generated a controller, still getting nothing.
The index page loads fine, but nothing beyond that.  If I go to
anything that should give me a 404, the page is just blank.  The
Webrick console just says a 500 (nothing explaining why), and there's
nothing in the development.log.  There is no server.log (should there
be?  I don't know).

Actually there is something in development.log, but unrelated to my
controller.  "Controllers::RailsInfoController: missing default helper
path rails_info_helper"

I'm really clueless as to what's going on.  OS X, Ruby 1.8.2, Rails
0.14.4.  I'd appreciate any help.

Pat M. (Guest)
on 2005-12-12 05:48
(Received via mailing list)
When I run script/console I get the following error:

baggio:~/work/mesafire pergesu$ ./script/console
Loading development environment.
/usr/lib/ruby/1.8/irb/completion.rb:10:in `require': No such file to
load -- readline (LoadError)
        from /usr/lib/ruby/1.8/irb/completion.rb:10
        from /usr/lib/ruby/1.8/irb/init.rb:218:in `require'
        from /usr/lib/ruby/1.8/irb/init.rb:218:in `load_modules'
        from /usr/lib/ruby/1.8/irb/init.rb:216:in `each'
        from /usr/lib/ruby/1.8/irb/init.rb:216:in `load_modules'
        from /usr/lib/ruby/1.8/irb/init.rb:21:in `setup'
        from /usr/lib/ruby/1.8/irb.rb:54:in `start'
        from /usr/bin/irb:13

Is my ruby install messed up?  Rails?  I've run fixrbconfig, but I
don't think that'd have anything to do with this anyway.

Steven S. (Guest)
on 2005-12-12 06:00
(Received via mailing list)
You may want to check this web site:

Sounds similar to your problem.  Be sure to read the comments
following the article as well.
Pat M. (Guest)
on 2005-12-12 06:12
(Received via mailing list)
Alright I ran the steps I needed, script/console runs fine, but I'm
still getting the 500 errors without any info in the browser, in the
console, or in development.log.  Thanks for that any
clue why the other stuff still isn't working?

Steven S. (Guest)
on 2005-12-12 06:24
(Received via mailing list)
You might try booting lighttpd as follows:

ruby script/server lighttpd

to see if that works or you minimally get an error indicating the
real problem.

Lastly, and sorry for stating the obvious, but please ensure the DB
is up.  I've seen apps that relied on MySQL (or other DB) that didn't
report much if that DB was down.
Pat M. (Guest)
on 2005-12-12 06:39
(Received via mailing list)
I created a totally new project and did script/server.  When I go to
the index page and click on "About your application's environment" I
get the error: - - [11/Dec/2005:21:31:32 MST] "GET /rails_info/properties
HTTP/1.1" 500 0

in the server console.  This is driving me totally crazy because I
have another app that I created just two days ago that's working just
fine.  I mean if I got some kind of error I could at least try to
trouble shoot this but this is just ridiculous.

Pat M. (Guest)
on 2005-12-12 06:54
(Received via mailing list)
The DB was up fine, as I said, another app was working great.

I have no clue what the issue is, but I remembered back to my Windows
days for the ultimate fix - reboot.  Now it's working.  I'm truly
clueless as to why, because I hadn't installed any new libs when it
was failing or anything...but it's working now so I don't particularly
care anymore.

Thanks for that link to the website, I appreciate it.

Scott B. (Guest)
on 2005-12-12 07:00
(Received via mailing list)
On Dec 11, 2005, at 11:51 PM, Pat M. wrote:

> Pat
If it happens again, try removing the session files from your temp dir
see if that straightens it out.  I've experienced the same thing and
I'm not
sure why it's not reporting the error these days.

Scott B.
Lunchbox Software
Steven S. (Guest)
on 2005-12-12 07:12
(Received via mailing list)
This sounds highly related to the error message you mentioned in your
original post:

"Controllers::RailsInfoController: missing default helper path

Looks like this was added in 14.4 (RC5).  I can't be much help here
as I'm on 14.3.  Sorry.
Juraci Krohling C. (Guest)
on 2005-12-12 16:38
(Received via mailing list)
I had this same problem on Friday, and a friend of mine had just
yesterday (both w/ Mac OS X 10.4.x) . The solution? A simple reboot.

I followed the traces but didn't found where exactly the problem is. It
goes until Controller instantiation, but it breaks for non-logical
reason. Then, I gave up, rebooted and everything goes fine.

This topic is locked and can not be replied to.