Forum: Ruby gem install rails hangs

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
bauer.mail (Guest)
on 2005-12-04 15:07
(Received via mailing list)
Doesnt looks rails-specific, any gem will hang after I get the followin
message: "Updating Gem source index for: http://gems.rubyforge.org".
The problem is identical to the one described here:
http://groups.google.com/group/comp.lang.ruby/brow...
      (after he had fixed his initial error).

Also, Tim's test script (from the url above) fails in a similar
fashion:

require 'socket'

hostname = ARGV[0]
puts "Making socket to #{hostname}"
sock = TCPSocket.new(hostname, 80)
mesg = "GET /yaml.Z HTTP/1.1\r\nHost: #{hostname}\r\n\r\n"
puts "writing to socket #{hostname}: " + mesg
sock.write mesg
puts "Wow, no hang!"

It doesnt make it past sock.write.  I'm using Ruby 1.8.2 (from the
one-click installer) and RubyGems 0.8.11 on Win Xp Pro x64.  I've also
tried 1.8.4 and had the same problems.  Anyone have any ideas?

Thanks,
Scott
vanek (Guest)
on 2005-12-04 15:28
(Received via mailing list)
just talking out loud here, trying to rule out the obvious.

first, can you ping gems.rubyforge.org?

at a command line, what happens when you type

   telnet gems.rubyforge.org 80

then type Control-D ENTER?
You should see HTML.
If not, can you

	telnet www.yahoo.com 80
	Control-D ENTER ENTER

Again, you should see a bunch of HTML.

Can you (perhaps temporarily) turn off the Windows firewall (it's on by
default).
   Control Panel -> Network Connections
		right click on 'Local Area Connection' and select 'Properties'
		Choose 'Advanced' tab, and select 'Windows Firewall' settings,
                 and then turn it off.

Do you have any other firewall software installed?

Does your computer sit behind a proxy server?
	If so, does the proxy server filter out some sites/ports?

Have you tried rebooting your computer, and, if you have a firewall,
rebooting the firewall?

do you see anything unusual when you do,
	netstat -a

If you are running a bunch of concurrent tcp/ip sessions, have you tried
changing the maximum number of allowed connections with
   EvID4226Patch.exe
   http://blog.davidkaspar.com/archives/2005/04/windo...
   http://lvllord.de/?lang=en&url=downloads

Are you logged on as an administrator?

Have you recently changed settings in 'Administrative Tools' -> 'Local
Security Settings'?

Does 'Administrative Tools' -> 'Event Viewer' show any errors
that could be causing this?

If none of those helped, I'm at a loss.


Windows XP ProSP2 (32 bit)
Cygwin Ruby 1.8.3
bauer.mail (Guest)
on 2005-12-04 22:20
(Received via mailing list)
Thanks for the ideas.  Everything you listed works as it should.  I've
tried disable the firewall, I'm not behind a proxy, I've rebooted,
havent touched anything in 'Local Security Policy', event viewer doesnt
show anything that looks related to the problem (some kind of cd rom
driver issues though).  I am logged in as Administrator as well.  I
dont have too many concurrent tcp/ip sessions either.  What should I
look for when using netstat -a to determine if anyting's screwy?  Here
the output I get:


Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    fizzy:epmap            fizzy:0                LISTENING
  TCP    fizzy:microsoft-ds     fizzy:0                LISTENING
  TCP    fizzy:1026             fizzy:0                LISTENING
  TCP    fizzy:1030             fizzy:0                LISTENING
  TCP    fizzy:1037             fizzy:1038             ESTABLISHED
  TCP    fizzy:1038             fizzy:1037             ESTABLISHED
  TCP    fizzy:netbios-ssn      fizzy:0                LISTENING
  TCP    fizzy:1426             virtual-www.mozilla.org:http  CLOSING
  TCP    fizzy:1431             66-195-250-153.gen.twtelecom.net:http
ESTABLISHED
  TCP    fizzy:1432             66-195-250-153.gen.twtelecom.net:http
ESTABLISHED
  TCP    fizzy:1435             216.129.107.21:http    ESTABLISHED
  UDP    fizzy:microsoft-ds     *:*
  UDP    fizzy:isakmp           *:*
  UDP    fizzy:1025             *:*
  UDP    fizzy:1220             *:*
  UDP    fizzy:ipsec-msft       *:*
  UDP    fizzy:ntp              *:*
  UDP    fizzy:ssdp             *:*
  UDP    fizzy:ntp              *:*
  UDP    fizzy:netbios-ns       *:*
  UDP    fizzy:netbios-dgm      *:*
  UDP    fizzy:ssdp             *:*

This is a fresh install of Windows x64 on my new Athlon 64 x2 3800+
system, I'm dyin to get ruby running properly here!
vanek (Guest)
on 2005-12-05 14:10
(Received via mailing list)
your network connection appears to be functioning normally,
which means your problem appears to be with Ruby, or the 32-bit
image of Ruby on your 64-bit system.

I would try installing Cygwin (http://www.cygwin.com/) and the Ruby
version that comes precompiled for it. Cygwin says they are 64-bit
compatible, thus should run on Windows x64.

If that doesn't work, I would look at compiling Ruby 1.8.2 natively
on your system.

Sorry, I can't think of an easier solution. Installing Cygwin is easy
and only takes a few minutes. Hopefully that will work (it works well
for me).

-lv
bauer.mail (Guest)
on 2005-12-05 18:25
(Received via mailing list)
Sounds like a plan, I'll try it this evening.  Thanks for the help!
This topic is locked and can not be replied to.