Forum: Ruby on Rails sessions => session when pluralization off

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
jamie (Guest)
on 2005-12-02 23:55
(Received via mailing list)
Just ran into quite a "gotcha" with using a session table and
pluralization turned off (because I'm building onto a legacy system).
I turned off pluralization with

ActiveRecord::Base.pluralize_table_names = false

and turned on the session table with

config.action_controller.session_store = :active_record_store

When I started up my dev server I got blank pages. No content at all.
None of the logs showed any errors at all. I couldn't get any info,
failures, errors, etc. Finally I reset the environment.rb file to
default and the app worked. After determining that using a file based
store was working, it dawned on me that "rake create_session_table"
creates a table named "sessions". Once I renamed the table to
"session" all worked.

Has anyone else encountered this? What amazed me is that I got no
info at all as to why the app was failing.

This topic is locked and can not be replied to.