Forum: Ruby on Rails ruby-ldap install problems

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
shaun (Guest)
on 2005-12-01 19:26
I'm trying to install ruby-ldap in windows environment. When I run 'ruby
extconf.rb' I continually recieve errors stating that it can't find
ldap.h and some other files despite even though I have provided the
directory location of these files. I have tried nearly every combination
os specifying library directory, openldap directory, and the directory
for the .h files.

C:\ldap\ruby-ldap-0.9.2>ruby extconf.rb --with-openldap2
--with-ldap-libdir=C:\ldap2-ruby\openldap-2.3.11\libraries\ --w
ith ldap-incdir=C:\ldap2-ruby\openldap-2.3.11\include
checking for ldap.h... no
checking for lber.h... no
checking for ldap_ssl.h... no
can't find ldap.h and lber.h
use the option '--with-ldap-dir'!

Does anybody know if I am missing something or doing something wrong?

-Shaun
This topic is locked and can not be replied to.