Forum: Ruby on Rails Anyone see similarly inconsistent code generation errors?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
duane.johnson (Guest)
on 2005-12-01 07:48
(Received via mailing list)
I'm curious to see if anyone else has been experiencing errors such
as the following at unpredictable times (usually after changing
something on a page and then re-loading it in development mode):

ArgumentError (negative argument):
     /vendor/rails/actionpack/lib/action_controller/
code_generation.rb:13:in `*'

NoMethodError (undefined method `shift' for -517611318:Fixnum):
     /vendor/rails/actionpack/lib/action_controller/
code_generation.rb:215:in `continue'

NoMethodError (undefined method `concat' for -517611318:Fixnum):
     /vendor/rails/actionpack/lib/action_controller/
code_generation.rb:202:in `add_segment'

TypeError (wrong instance allocation):
     /vendor/rails/actionpack/lib/action_controller/
code_generation.rb:65:in `new'

TypeError (-517611318 is not a class/module):
     /vendor/rails/actionpack/lib/action_controller/
code_generation.rb:66:in `dup'

These errors happen every once in a while (maybe 1/20 times on
average), and go away if I re-load the page once or twice.  I'm
running Edge Rails with Ruby 1.8.3 on Mac OS X 10.4.3.  They errors
been happening for two or three weeks so it's not a bleeding edge
addition to Rails, whatever the cause.

Ideas anyone?

Duane J.
(canadaduane)
This topic is locked and can not be replied to.