Forum: Ruby on Rails Switchtower Windows question

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
dan (Guest)
on 2005-11-30 17:42
(Received via mailing list)
Hi,

Im trying to deploy an application from Windows using Switchtower.  Im
hitting a hitch because my SVN repos needs authentication.  I get
something like:

[out :: dev.vivabit.net] Authentication realm:
<http://svn.vivabit.net:80> Vivabit Subversion
[out :: dev.vivabit.net] Password for 'root':
[out :: dev.vivabit.net] subversion is asking for a password
[out :: dev.vivabit.net] Authentication realm:
<http://svn.vivabit.net:80> Vivabit Subversion
[out :: dev.vivabit.net] Username:

Then it hangs.  Ive tried typing the username but I can't get past
this point.  Ive also tried adding the username/pass to the repos url
eg:

set :repository, "http://user:removed_email_address@domain.invalid/...."

But that fails in the same way.  Any suggestions?  Are there some
deploy.rb settings Im missing etc?

Thanks,

--
Dan W.
http://www.danwebb.net
This topic is locked and can not be replied to.