Forum: Ruby on Rails textarea with large data, bug ?

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Olivier V. (Guest)
on 2005-11-14 20:40

I have a problem with a simple form having a textarea and few buttons,
radio boxes...
When I feed my textarea with a lot of text (about > 200 lines), it fails
lamentably, otherwise it works fine.

Here the params array, as given by the exceptions caught on action

Parameters: {"demi_choix_1"=>"55", "demi_choix_2"=>"59",
"demi_choix_3"=>"-1dangerous to public [...] disturbances.", "human
[...] disturbances."=>""}

"demi_choix_3" should be an integer, it loses many of original form
attributes, and has an attribute whose key is a section of the original
textarea text with a value of "".

my template looks like this:

<%= form_tag :action => 'generate_doc', :id => @concours, :is_email =>
@is_email %>
  <%= text_area 'document', 'content', :cols => '90' %> <br />
<%= end_form_tag %>

This may be a bug, or maybe i missed a configuration option, or
something else. I'm running the latest rails version (0.14.3) on debian
sarge, under fcgi, with ruby 1.8.2.
Has someone an idea ? Many thanks !
dr.frog (Guest)
on 2005-11-14 20:46
(Received via mailing list)
make sure its not your  servers post limit

most are capped off at 256kb of data

----- Original Message -----
From: "olivier victor" <removed_email_address@domain.invalid>
To: <removed_email_address@domain.invalid>
Sent: Monday, November 14, 2005 10:40 AM
Subject: [Rails] textarea with large data, bug ?
Olivier V. (Guest)
on 2005-11-14 21:25
dr.frog wrote:

> make sure its not your  servers post limit
> most are capped off at 256kb of data
> iirc

I don't think it was, to be sure I put:
  LimitRequestBody 0
in my apache2 config file.

I tried using Webrick, and it worked fine... There is probably some
problems related to my apache and fcgi configuration, I'll check for
that later.

Thank for your answer.
This topic is locked and can not be replied to.