Split users

Hi,
I’m developing a module for A/B split testing.
The splitting is defined as:

users_split “${remote_addr}AAA” $variant {
0.5% one;
2.0% two;
- “”;
}

The question is: what is the better English name:
users_split
user_split
clients_split
client_split
or something else ?


Igor S.
http://sysoev.ru/en/

How about with_split?

:smiley:

‘distribute’ ?

rr

----- Original Message -----
From: “Igor S.” [email protected]
To: [email protected]
Sent: Wednesday, May 12, 2010 5:35 PM
Subject: split users

How a_b_split?

-peter

Hello Igor,

The question is: what is the better English name:
users_split
user_split
clients_split
client_split
or something else ?

I would go with “split_clients”, but “clients_split” seems acceptable if
you
want to keep it within “clients_” namespace.

Best regards,
Piotr S. < [email protected] >

On 12/05/2010 15:35, Igor S. wrote:

The question is: what is the better English name:
users_split
user_split
clients_split
client_split
or something else ?

distribute_requests
dist_requests
split_requests
request_split

Phillip B Oldham
ActivityHQ
[email protected] mailto:[email protected]


Policies

This e-mail and its attachments are intended for the above named
recipient(s) only and may be confidential. If they have come to you in
error, please reply to this e-mail and highlight the error. No action
should be taken regarding content, nor must you copy or show them to
anyone.

This e-mail has been created in the knowledge that Internet e-mail is
not a 100% secure communications medium, and we have taken steps to
ensure that this e-mail and attachments are free from any virus. We must
advise that in keeping with good computing practice the recipient should
ensure they are completely virus free, and that you understand and
observe the lack of security when e-mailing us.

On Wed, May 12, 2010 at 12:36:40PM -0400, Peter Portante wrote:

How a_b_split?

I got to learn the “A/B split” term a couple of hours ago :slight_smile:
I do not think that it will be good name.

To: [email protected]

      -                     "";


nginx mailing list
[email protected]
nginx Info Page


Igor S.
http://sysoev.ru/en/

How about with_split?

or just split

Hello!

On Wed, May 12, 2010 at 06:35:43PM +0400, Igor S. wrote:

The question is: what is the better English name:
users_split
user_split
clients_split
client_split
or something else ?

Maybe something like “map_split”? I believe it’s really similar
to map module, and the only difference is mapping algorithm.

Maxim D.

On Thu, May 13, 2010 at 09:03:56AM +0800, Ken wrote:

How about with_split?

or just split

“split” is too good name for this. I reserve it for something else.

}
Igor S.
Igor Sysoev


nginx mailing list
[email protected]
nginx Info Page


nginx mailing list
[email protected]
nginx Info Page


Igor S.
http://sysoev.ru/en/

On Wed, May 12, 2010 at 7:00 PM, Phillip O. [email protected]
wrote:

On 12/05/2010 15:35, Igor S. wrote:

Hi,
I’m developing a module for A/B split testing.

split_requests

+1

On Wed, May 12, 2010 at 06:00:59PM +0100, Phillip O. wrote:

split_requests
request_split

I still considering two initial varaints: user_split or users_split.
Does “users_split” sound good or not for English ear ?


Igor S.
http://sysoev.ru/en/

On 13/05/2010 12:47, Igor S. wrote:

distribute_requests
dist_requests
split_requests
request_split

I still considering two initial varaints: user_split or users_split.
Does “users_split” sound good or not for English ear ?

I believe “client_split” would be better english rather than
“user_split”; when seeing “user” one would think of a system user,
whereas “client” is preferrable as something which connects to a system
(in this case a webserver).

“split_clients” would be even better - this dictates the block’s
intention rather than what it “is”, which would to mind easier when
writing the block. Other things could be “split_” also, in future
modules: “split_backends” for example.

Phillip B Oldham
ActivityHQ
[email protected] mailto:[email protected]


Policies

This e-mail and its attachments are intended for the above named
recipient(s) only and may be confidential. If they have come to you in
error, please reply to this e-mail and highlight the error. No action
should be taken regarding content, nor must you copy or show them to
anyone.

This e-mail has been created in the knowledge that Internet e-mail is
not a 100% secure communications medium, and we have taken steps to
ensure that this e-mail and attachments are free from any virus. We must
advise that in keeping with good computing practice the recipient should
ensure they are completely virus free, and that you understand and
observe the lack of security when e-mailing us.

“users_split” is better

2010/5/13 Igor S. [email protected]

On Thu, May 13, 2010 at 03:11:52PM +0100, Phillip O. wrote:

or something else ?

I believe “client_split” would be better english rather than
“user_split”; when seeing “user” one would think of a system user,
whereas “client” is preferrable as something which connects to a system
(in this case a webserver).

“split_clients” would be even better - this dictates the block’s
intention rather than what it “is”, which would to mind easier when
writing the block. Other things could be “split_” also, in future
modules: “split_backends” for example.

Thank you. I will use split_clients.


Igor S.
http://sysoev.ru/en/