Forum: Ruby on Rails Issues with MySql database encoding

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mindtonic (Guest)
on 2009-06-09 20:44
(Received via mailing list)
Hello, I am working on an international project that requires UTF-8
encoding for letter characters.  I have successfully changed my local
development machine to UTF-8 and all characters are holding as they
should.  However, my production server is a Solaris box, and it is not
holding the proper characters even after I change the database
encoding.

I would prefer not to use htmlentites as it can be quite messy and
does not yield an accurate search result.

Does anyone have any suggestions?
Mindtonic (Guest)
on 2009-06-09 20:49
(Received via mailing list)
database.yml is set properly (has been from the beginning):

production:
  adapter: mysql
  encoding: utf8
Frederick C. (Guest)
on 2009-06-09 20:57
(Received via mailing list)
On Jun 9, 5:48 pm, Mindtonic <removed_email_address@domain.invalid> wrote:
> database.yml is set properly (has been from the beginning):
>
> production:
>   adapter: mysql
>   encoding: utf8
>
Are the encodings for the various columns set properly?

Fred
Freddy A. (Guest)
on 2009-06-09 22:08
(Received via mailing list)
How was the database created? Through MySQL SQL import? Does the sql
have UTF-8?
This topic is locked and can not be replied to.