Forum: Ruby Problems with Rubygems on 1.9.0 under multiruby

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
James C. (Guest)
on 2009-06-03 22:43
(Received via mailing list)
Hi all,

Trying to get multiruby (from ZenTest) set up on Ubuntu. So far I've run
the
following and got 4 working installs:



sudo gem install ZenTest
multiruby_setup update:rubygems
multiruby_setup mri:tar:1.8.6
multiruby_setup mri:tar:1.8.7
multiruby_setup mri:tar:1.9.0
multiruby_setup mri:tar:1.9.1

wget http://www.blue.sky.or.jp/atelier/ruby/ruby-zlib-0...
tar zxf ruby-zlib-0.6.0.tar.gz
cd ruby-zlib-0.6.0/
~/.multiruby/install/1.8.6-p368/bin/ruby extconf.rb
make && make install
~/.multiruby/install/1.8.7-p160/bin/ruby extconf.rb
make && make install
~/.multiruby/install/1.9.0-5/bin/ruby extconf.rb
make && make install
~/.multiruby/install/1.9.1-p129/bin/ruby extconf.rb
make && make install

multiruby_setup update:rubygems
multiruby -S gem install --no-ri --no-rdoc --development test-unit



This last command runs on everything but 1.9.0:



$ multiruby -S gem install --no-ri --no-rdoc --development test-unit
building and installing 1.8.6-p368
Running command: (nice make -j4; nice make) > log.build 2>&1
Running command: make install > log.install 2>&1
Running command: ../ruby ./setup.rb --no-rdoc --no-ri > ../log.rubygems
2>&1
building and installing 1.8.7-p160
Running command: (nice make -j4; nice make) > log.build 2>&1
Running command: make install > log.install 2>&1
Running command: ../ruby ./setup.rb --no-rdoc --no-ri > ../log.rubygems
2>&1
building and installing 1.9.0-5
Running command: (nice make -j4; nice make) > log.build 2>&1
Running command: make install > log.install 2>&1
building and installing 1.9.1-p129
Running command: (nice make -j4; nice make) > log.build 2>&1
Running command: make install > log.install 2>&1

VERSION = 1.8.6-p368
CMD     = ~/.multiruby/install/1.8.6-p368/bin/ruby -S gem install
--no-ri
--no-rdoc --development test-unit

Successfully installed rubyforge-1.0.3
Successfully installed rake-0.8.7
Successfully installed hoe-2.0.0
Successfully installed test-unit-2.0.2
4 gems installed

RESULT = 0

VERSION = 1.8.7-p160
CMD     = ~/.multiruby/install/1.8.7-p160/bin/ruby -S gem install
--no-ri
--no-rdoc --development test-unit

Successfully installed rubyforge-1.0.3
Successfully installed rake-0.8.7
Successfully installed hoe-2.0.0
Successfully installed test-unit-2.0.2
4 gems installed

RESULT = 0

VERSION = 1.9.0-5
CMD     = ~/.multiruby/install/1.9.0-5/bin/ruby -S gem install --no-ri
--no-rdoc --development test-unit

ERROR:  Error installing test-unit:
    hoe requires RubyGems version >= 1.3.1

RESULT = 256

VERSION = 1.9.1-p129
CMD     = ~/.multiruby/install/1.9.1-p129/bin/ruby -S gem install
--no-ri
--no-rdoc --development test-unit

Successfully installed rubyforge-1.0.3
Successfully installed rake-0.8.7
Successfully installed hoe-2.0.0
Successfully installed test-unit-2.0.2
4 gems installed

RESULT = 0

TOTAL RESULT = 1 failures out of 4

Passed: 1.9.1-p129, 1.8.7-p160, 1.8.6-p368
Failed: 1.9.0-5



My question is -- is it worth testing on 1.9.0 or is everyone using
1.9.1
instead? If it's still worth testing on 1.9.0, how do I fix the above?
multiruby appears to have installed Rubygems 1.3.4, though I guess the
version shipped with Ruby 1.9.0 predates this.
Bernard K. (Guest)
on 2009-06-04 01:30
(Received via mailing list)
On Jun 3, 2:42 pm, James C. <removed_email_address@domain.invalid> wrote:
> multiruby_setup mri:tar:1.8.7
> ~/.multiruby/install/1.9.0-5/bin/ruby extconf.rb
> building and installing 1.8.6-p368
> building and installing 1.9.1-p129
> Successfully installed test-unit-2.0.2
> Successfully installed hoe-2.0.0
>     hoe requires RubyGems version >= 1.3.1
> Successfully installed test-unit-2.0.2
> instead? If it's still worth testing on 1.9.0, how do I fix the above?
> multiruby appears to have installed Rubygems 1.3.4, though I guess the
> version shipped with Ruby 1.9.0 predates this.
>
> --
> James C.

IMHO,  you should not need Ruby-1.9.0 since Ruby-1.9,1 is a stable
version.

Personally I would not install Ruby-1.8.7 since it is neither fish nor
bird ... it istradles 1.8.6 and 1.9.1 ... if you're going to migragate
to 1.9.1 there's no point to go through 1.8.7

just my 2 cents for a newby
This topic is locked and can not be replied to.