Forum: Ruby on Rails fields dont display on browser

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Asanka M. (Guest)
on 2009-06-03 10:38
Attachment: rails.jpg (0 Bytes)
Hi

I'm new to Rails. i am using aptana Radrails and rad rails standalone
version for my development. Followed some tutorials on the web on how to
create a simple project.

When I fire up the browser the fields and labels are not being
displayed. I also tried IE external to RadRails, and FireFox. Same
thing. I see 'show edit destroy', and 'new', and that's it. I can click
on 'new', then click on 'create', and a record does get added to the
MySQL db (all spaces).

I added a default value to one of the fields and that isn't displayed
either. I've deleted the project and did it again, same result. Deleted
that one and followed the example from the Ruby on Rails for Dummies
book...same result.

Any suggestions on what could be causing this? pls see the attachemnt
too

thank you
Ar C. (Guest)
on 2009-06-03 17:01
Umm... you have no fields defined in your views?

What is in index.html.erb, or show.html.erb, or new and edit erb files?

Or perhaps your model has only id and nothing else?

Hard to tell without some source to look at.
Asanka M. (Guest)
on 2009-06-03 19:25
Attachment: test.zip (0 Bytes)
Hi Ar Chron

first of all thank you very much for your reply.

i followed many examples all seems to be pretty much same. here is one
http://tv.aptana.com/videos/introduction-to-radrai...

index.html.erb
<h1>Listing employees</h1>
<table>
  <tr>
  </tr>
<% @employees.each do |employee| %>
  <tr>
    <td><%= link_to 'Show', employee %></td>
    <td><%= link_to 'Edit', edit_employee_path(employee) %></td>
    <td><%= link_to 'Destroy', employee, :confirm => 'Are you sure?',
:method => :delete %></td>
  </tr>
<% end %>
</table>
<br />
<%= link_to 'New employee', new_employee_path %>


new.html.erb
<h1>New employee</h1>
<% form_for(@employee) do |f| %>
  <%= f.error_messages %>
  <p>
    <%= f.submit 'Create' %>
  </p>
<% end %>
<%= link_to 'Back', employees_path %>


show.html.erb
<%= link_to 'Edit', edit_employee_path(@employee) %> |
<%= link_to 'Back', employees_path %>

edit.html.erb
<h1>Editing employee</h1>

<% form_for(@employee) do |f| %>
  <%= f.error_messages %>

  <p>
    <%= f.submit 'Update' %>
  </p>
<% end %>

<%= link_to 'Show', @employee %> |
<%= link_to 'Back', employees_path %>




i have also attached the project for your reference.

i am new to RoR so i really appreciate you help to get stuff started.

Thank you Again
E. Litwin (Guest)
on 2009-06-03 21:09
(Received via mailing list)
None of your views have any fields - just links for Create, Edit,
Back, New, etc.

It looks like you might have generated scaffolding without specifying
any field attributes.

On Jun 3, 8:25 am, Asanka M. <removed_email_address@domain.invalid>
Asanka M. (Guest)
on 2009-06-04 05:39
hi Litwin

i am not quit sure how to build a app from A-Z as i am new to RoR, i am
currently following Rails for dummies book. i did exactly according to
the book but not sure why its not working . can y any of you pls post me
a video or tutorial URL with correct steps to get me started pls pls
pls.

thank you
A
Asanka M. (Guest)
on 2009-06-04 05:44
may be i am using incorrect tool for my development. if so can any one
point me to the correct tools

thank you
A
Sijo k. (Guest)
on 2009-06-04 08:03
http://www.tutorialspoint.com/ruby-on-rails/
    This is good for beginners (Rails 2.1)
   There are so many others available on net
Also try to get books
1.Agile web development with Rails
2.Beginning RubyOnRails (wrox publications)


Sijo
Vlad V. (Guest)
on 2011-01-04 22:29
Hi Asanka,

I have same issue. Did you find what was wrong with that example?
If yes please let me know how to fix it.

Thank you,
Vlad
Tim S. (Guest)
on 2011-01-04 22:53
(Received via mailing list)
It looks like the form_for helper needs to be using a print ERB
expression
tag instead of ERB code tag:

<%*=* form_for(@employee) do |f| %>

instead of

<% form_for(@employee) do |f| %>
Frederick C. (Guest)
on 2011-01-05 05:51
(Received via mailing list)
On Jan 4, 8:29pm, Vlad V. <removed_email_address@domain.invalid> wrote:
> Hi Asanka,
>
> I have same issue. Did you find what was wrong with that example?
> If yes please let me know how to fix it.
>

I'd guess that the tutorial being followed assumes the presence of
dynamic scaffolding, which hasn't been the case for a long time (was
removed in rails 2 I think)

Fred
This topic is locked and can not be replied to.