Forum: Ruby on Rails Mi browser no muestra el formato para captura desplegado

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jose G. (Guest)
on 2009-05-30 01:14
Hola,

Soy nuevo totalmente con ruby on rails..de hecho durante 15 a#os
programe con un RAD que no maneja codigo asi que estoy intentando
retomar este tipo de lenguajes nuevamente..y vaya que si han cambiando.

 Estoy siguiendo un tutorial que indica como hacer una aplicacion
sencilla llamada 'DEPOT', despues de sortear algunos problemas de
configuracion de mysql y el mismo rails logre llegar al punto donde se
me indica que ejecute el comando:

 >ruby script/generate scaffold Product

Segun esto este comando me generara el controlador, el modelo y la vista
adecuados para ejecutar las altas bajas y cambios a mi tabla de
'Products' que previamente defini en mi base de datos
(depot_development)en mysql.

Una vez que levanto el servidor ejecuto en el browser:
 http://localhost:3000/Products

y el browser me regresa lo siguiente:


Listing products
Show   Edit   Destroy
Show   Edit   Destroy
Show   Edit   Destroy

New product


y bueno, efectivamente la tabla tiene ya 3 registros, la cosa aqui es
que no me muestra el contenido de los registros solo las opciones para
manipularlos o la opcion para crear uno nuevo...si le doy click a 'New
product' me muestra otra pagina pero no me muestra los campos para yo
ingresar datos.

de hecho borre la aplicacion y volvi a generar todo segun el demo pero
nada, sigue igual.

Algun paso hice mal o no se que pasa..pareciera que el controlador no
esta invocando las vistas (formatos) de despliegue.

Alguna idea o comentario seran de gran ayuda.


Gracias.

Jose
Cesar D. (Guest)
on 2009-05-30 04:11
(Received via mailing list)
It must be a question for spanish list, what do you think?

Cesar

_______________________________________________
Gnu/Linux count user #416024

Skype: cesarstafe
Jose G. (Guest)
on 2009-05-30 20:02
Cesar Diaz wrote:
> It must be a question for spanish list, what do you think?
>
> Cesar
>
> _______________________________________________
> Gnu/Linux count user #416024
>
> Skype: cesarstafe

Yes,you are right Cesar, I am sorry, I already left the message in the
right place,  anyway if you know something about what I am asking for
please help me, I will appreciate it.

Jose.
Franco C. (Guest)
on 2009-05-31 02:11
(Received via mailing list)
Jose:

You must use specify to the generator the fields like this:

ruby script/generate scaffold Product name:string description:string

and so on with all the fields in the database. If you want to add one
field in a previously created scaffold you can do it editing the files
in the app/views/products/ directory.

Regards.

Franco C..

On May 30, 1:02 pm, Jose G. <removed_email_address@domain.invalid>
Jose G. (Guest)
on 2009-05-31 07:34
Thanks Franco, the problem was solved, someone else from spanish list
suggested the same as you and it worked fine.

Thanks again !
Jose

Franco C. wrote:
> Jose:
>
> You must use specify to the generator the fields like this:
>
> ruby script/generate scaffold Product name:string description:string
>
> and so on with all the fields in the database. If you want to add one
> field in a previously created scaffold you can do it editing the files
> in the app/views/products/ directory.
>
> Regards.
>
> Franco C..
>
> On May 30, 1:02�pm, Jose G. <removed_email_address@domain.invalid>
This topic is locked and can not be replied to.