Forum: GNU Radio USRP Quartus project same version as GNURadio ?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mark Porter (Guest)
on 2009-05-22 19:36
(Received via mailing list)
Hi,

I'm trying to RUN my own RBF file with the Quartus project
(usrp_std.qpf).
The compilation goes through and I get usrp_std.rbf . However when I try
to
create a usrp source like so :

self.fpga_filename = "usrp_std.rbf"
self.u = usrp.source_c (decim_rate = self.usrp_decim,
fpga_filename=self.fpga_filename, mux =0)

I get an error

File "/usr/lib/python2.6/site-packages/gnuradio/usrp/usrp_swig.py", line
1607 in source_c
      return _usrp_swig.source_c(*args, **kwargs)
*RuntimeError: can't open usrp*

*Using the precompiled rbf works flawlessly (e.g. std_4rx_0tx.rbf)*

Does the Quartus project have to come from the exact same gnuradio
version
as the one running on the device (I have release 3.1.3 on Quartus and
3.1.3+svn10302 r6.1 on the device itself) ?

Thanks
Sebastiaan H. (Guest)
on 2009-05-22 21:09
(Received via mailing list)
Mark

Have you made sure that the .rbf is in /usr/local/share/usrp/rev4?
Also, I think that when you issue ls -l when you are in the directory
containing the .rbf file, you should get:

-rw-r--r-- usrp_std.rbf

Sebastiaan
Mark Porter (Guest)
on 2009-05-22 21:29
(Received via mailing list)
Thanks for the pointers.

I had already put my RBF where the others are (/usr/share/usrp/rev4) and
the
others (e.g. std_4rx_0tx.rbf) are working.
I fixed my file permissions, it is still not working, I was root
anyway...

Other hypotheses : Newer version of Quartus, gnuradio not built on
Windows
machine (only using fpga files in /usrp/fpga/...), std.ihx from same
version
as the one used to compile verilog.

Thanks for your input

Mark
Mark Porter (Guest)
on 2009-05-22 22:31
(Received via mailing list)
Issue fixed thanks.
Eric B. (Guest)
on 2009-05-22 22:37
(Received via mailing list)
On Fri, May 22, 2009 at 11:34:49AM -0400, Mark Porter wrote:
> I get an error
> 3.1.3+svn10302 r6.1 on the device itself) ?
>
> Thanks
> Mark

Mark,

Can you please post the entire backtrace?  If the library can't find
your code, it'll print something like,

    fprintf (stderr, "Can't find fpga bitstream: %s\n", proto_filename);

Eric
Eric B. (Guest)
on 2009-05-22 22:46
(Received via mailing list)
On Fri, May 22, 2009 at 02:30:19PM -0400, Mark Porter wrote:
> Issue fixed thanks.

So that the archive has the answer, what was the fix?

Eric
Mark Porter (Guest)
on 2009-05-25 16:13
(Received via mailing list)
Sure,

The RBF was loading properly, except that my test decimation value (256)
was
invalid for the new RBF, which was not clear to me. I thank you for your
help in eliminating causes.

Mark
This topic is locked and can not be replied to.