Forum: Rails deployment Deploy with specific earlier version of capistrano

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Max W. (Guest)
on 2009-05-22 18:07
I started a new app, using the latest version of capistrano (2.5.5) to
deploy.  All fine.  But, when i've gone back to an app i started
earlier, i can't deploy it - i get this error:

failed: "sh -c \"sudo -p 'sudo password: ' chown app_e_learning_resource
/var/www/apps/e_learning_resource/shared/log/mongrel.log\"" on
prelive.ourhost.com

Now, i thought that this was maybe because of some differences in
capistrano between the new version and the one i was using previously
(2.4.3).  So, i'm trying to deploy using the earlier version of
capistrano.

According to this page...

http://www.42.mach7x.com/2008/02/14/using-older-ca...

...i do this by putting the required version in underscores: eg

cap _2.4.3_ deploy STAGE=prelive

But, when i do this, i get this error:
/usr/local/lib/site_ruby/1.8/rubygems.rb:149:in `activate': can't
activate capistrano (> 2.5.0, runtime), already activated
capistrano-2.4.3 (Gem::Exception)

Looking down the trace for the first reference to anything in my code,
the problem seems to occur when i try to require 'deprec'.

Can anyone give me any help/advice?
thanks
max
This topic is locked and can not be replied to.