Forum: Ruby on Rails activeresource-2.3.2 HTTPHeaderSyntaxError

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
pekeler (Guest)
on 2009-05-20 23:44
(Received via mailing list)
Hi,

I'm upgrading my app from 2.2.2 to 2.3.2 and am having a problem with
ActiveResource.

    class FooResource < ActiveResource::Base
      self.site = "whatever"
      self.element_name = "foo"
    end

    FooResource.create(:bar => 'baz')

raises:

    Net::HTTPHeaderSyntaxError: wrong Content-Length format
      from /usr/local/lib/ruby/1.8/net/http.rb:1334:in `content_length'
      from /usr/local/lib/ruby/1.8/net/http.rb:2210:in `read_body_0'
      from /usr/local/lib/ruby/1.8/net/http.rb:2173:in `read_body'
      from /usr/local/lib/ruby/1.8/net/http.rb:846:in `post'
      from /usr/local/lib/ruby/1.8/net/http.rb:1053:in `request'
      from /usr/local/lib/ruby/1.8/net/http.rb:2136:in `reading_body'
      from /usr/local/lib/ruby/1.8/net/http.rb:1052:in `request'
      from /usr/local/lib/ruby/1.8/net/http.rb:1037:in `request'
      from /usr/local/lib/ruby/1.8/net/http.rb:543:in `start'
      from /usr/local/lib/ruby/1.8/net/http.rb:1035:in `request'
      from /usr/local/lib/ruby/1.8/net/http.rb:845:in `post'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/connection.rb:149:in `send'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/connection.rb:149:in `request'
      from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/
active_support/core_ext/benchmark.rb:17:in `ms'
      from /usr/local/lib/ruby/1.8/benchmark.rb:308:in `realtime'
      from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/
active_support/core_ext/benchmark.rb:17:in `ms'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/connection.rb:149:in `request'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/connection.rb:134:in `post'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/base.rb:995:in `create'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/base.rb:796:in `save_without_validation'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/validations.rb:248:in `save'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/base.rb:465:in `create'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/base.rb:465:in `tap'
      from /usr/local/lib/ruby/gems/1.8/gems/activeresource-2.3.2/lib/
active_resource/base.rb:465:in `create'
      from (irb):6>>

I'm using ruby 1.8.7p160 on OSX, also tried different ruby versions.
This is working fine with rails 2.2.2. Has anyone dealt with this
problem before?

Thanks,
Christian
pekeler (Guest)
on 2009-05-21 21:49
(Received via mailing list)
Turns out that Rails 2.3.2 (specifically Rack) is incompatible with
Mongrel 1.0.1. Updating to the latest Mongrel gem 1.1.5 solved the
problem.

Christian
This topic is locked and can not be replied to.