Forum: NGINX help with memcache?

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ilan B. (Guest)
on 2009-05-19 21:49
(Received via mailing list)
Hi All,

Setting up a local environment for testing purposes.  CenOS 5.3, PHP
with php-fpm, etc.

Installed and setup memcache.

Switched php.ini settings to use memcache as session handler.

phpinfo and php test script to use memcache server show settings are OK.

Session management... not working.  I'm really stuck... I can't figure
where to look... Basically, what's happening is that php is not
communicating with the memcached daemon for session management... but I
don't know why... can anyone point me in the right direction?  I've gone
and down newsgroups and support sites... and have tried installing /

E. Johnson (Guest)
on 2009-05-20 03:02
(Received via mailing list)
Have you tried invoking the daemon w/ 'memcached -vv'? This runs the
while showing requests as they come in.
Ilan B. (Guest)
on 2009-05-20 04:32
(Received via mailing list)
Thank you for the suggestion, I did just that.

There were 2 things:

1) a version mismatch between the memcache server and what php was
2) the software I was running wasn't configured properly, although I
that (1) was the primary issue.

Sorry for posting this on this group... as it wasn't nginx specific...
site is running on Nginx of course :-).
This topic is locked and can not be replied to.