Forum: Ruby on Rails Problems with upload using attachment_fu

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Nerdaniel (Guest)
on 2009-05-19 11:18
(Received via mailing list)
Hello everyone,

I'm having problems with :html => { :multipart => true } in my edit
form. It doesn't returns the image in the parameter, so everything
fails with this errors:

There were problems with the following fields:

    * Size can't be blank
    * Size is not included in the list
    * Content type can't be blank
    * Content type is not included in the list
    * Filename can't be blank

A friend of mine said that he had this problem in windows and I am in
a mac 10.5.6. =/

If I put multipart off it gives the same error. Everything I
implemented was following attachment_fu tutorials all over the net.
This is my edit:

= error_messages_for :user, :avatar

- form_for(@user, :url => { :action => 'update' }, :html =>
{ :multipart => true }) do |f|
  = f.label "avatar"
  %br
  = f.file_field :avatar
  %br
  %br
  = f.submit "save image!"

Thx!
Franco C. (Guest)
on 2009-05-19 15:20
(Received via mailing list)
The file field must be named "uploaded_data", try with that.

Regards.

Franco C..
Nerdaniel (Guest)
on 2009-05-19 17:59
(Received via mailing list)
I tryed and still the same. =/
This topic is locked and can not be replied to.