Forum: NGINX php-fpm for 5.2.9

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ilan B. (Guest)
on 2009-05-18 19:16
(Received via mailing list)
Hi All,

This question is not exactly related to Nginx (sorry), but is related
to our php configuration for Nginx.

There have been many discussions about php / php-fpm and the fact that
there's no php-fpm version for php 5.2.9.  I'm not 100% versed on
these topics, so bear with me.  There's also been discussion regarding
a patch that would have to be applied in order to compile php 5.2.9
with current php-fpm 5.2.8.

We are currently running php 5.2.9 with php-fpm 5.2.8 (no patch
applied).  Is that an issue?  If there were errors, where would I see
them?  If I do need to apply some kind of patch to php-fpm, where do I
get it from?

Any help would be appreciated, thanks!

btw, we used Nginx on http://www.spellingcity.com.  The site is a high
traffic site (20m page views a month and growing) and Nginx has been a
super star in terms of performance for us.  Frankly, I don't think
we're even making it work all that hard yet.
Floren M. (Guest)
on 2009-05-18 20:23
(Received via mailing list)
Attachment: patch.tar.gz (0 Bytes)
Hi,

> these topics, so bear with me.  There's also been discussion regarding
> a patch that would have to be applied in order to compile php 5.2.9
> with current php-fpm 5.2.8.

Use this patch, it works for me with PHP 5.2.9 version.
I would like to know also what is going on with Andrei... and the reason
why he does not post any news.

Regards,

Floren
Ilan B. (Guest)
on 2009-05-18 20:41
(Received via mailing list)
Floren,

Thanks!!!

Could you clarify for me how to actually install this patch?  I'm not
that familiar with this process just yet.  I am compiling php directly
so can include it in my php script.

What I'm not clear on, is that 5.2.9 with phpfpm 5.2.8 is working...
so what's the purpose of the patch?

Again, my apologies for having this non-nginx discussion on here...
really appreciate the support.
Floren M. (Guest)
on 2009-05-18 23:22
(Received via mailing list)
Hi Ilan,

> so can include it in my php script.
>
> What I'm not clear on, is that 5.2.9 with phpfpm 5.2.8 is working...
> so what's the purpose of the patch?

The patch is not the same, compared to 5.2.8 one available on Andrei's
site.
Do a diff to see the changes. As for applying it, simply follow these
instructions:
http://php-fpm.anight.org/docs.html

Regards,

Floren
APseudoUtopia (Guest)
on 2009-05-19 14:32
(Received via mailing list)
2009/5/18 Igor S. <removed_email_address@domain.invalid>:
>> > these topics, so bear with me.  There's also been discussion regarding
>> > btw, we used Nginx on http://www.spellingcity.com.  The site is a high
>> received it from the php mailing list when asking about both fpm and
>> spawn-fcgi). I eventually decided to use spawn-fcgi instead.
>
> The patch is too big and has been bounced.
> Please put it on some site.
>
>

Sorry about that. I uploaded the patch here:
http://somerandomguys.info/php-fpm.5.2.9.patch
This topic is locked and can not be replied to.