Forum: GNU Radio Unable to find USRP#0

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Teodora P. (Guest)
on 2009-05-18 15:28
Hi

Can anyone please help me?  I am using gnuradio3.1.3.
When I try to run usrp_benchmark_usb.py, I get the a RuntimeError:
Unable to find USRP #0.

When I issue

ls -lR /dev/bus/usb | grep usrp,

I didn't get any message.
This is the first time that I connect USRP board to PC.
Please help me.

Thanks a lot.

Teodora

This is a log:

Testing 2MB/sec... Traceback (most recent call last):
  File "./usrp_benchmark_usb.py", line 106, in <module>
    main ()
  File "./usrp_benchmark_usb.py", line 96, in main
    ok = run_test (rate, verbose)
  File "./usrp_benchmark_usb.py", line 63, in run_test
    usrp_tx = usrp.sink_s (0, tx_interp)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py", line
229, in __init__
    _ensure_rev2(which)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py", line
85, in _ensure_rev2
    v = _look_for_usrp(which)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py", line
79, in _look_for_usrp
    raise RuntimeError, "Unable to find USRP #%d" % (which,)
RuntimeError: Unable to find USRP #0
Johnathan C. (Guest)
on 2009-05-18 19:38
(Received via mailing list)
On Mon, May 18, 2009 at 4:28 AM, Teodora P. 
<removed_email_address@domain.invalid>
wrote:

> Can anyone please help me?  I am using gnuradio3.1.3.
> When I try to run usrp_benchmark_usb.py, I get the a RuntimeError:
> Unable to find USRP #0.
>
> When I issue
>
> ls -lR /dev/bus/usb | grep usrp,
>
> I didn't get any message.

It is likely that you do not have the permissions set correctly to
allow your user account to have access to the USRP hardware.  Try
running as root; if everything works, then this is the case.

To allow a non-root user to access the USRP, follow the instructions
here:

http://gnuradio.org/trac/wiki/UdevConfig

Johnathan
Teodora P. (Guest)
on 2009-05-19 13:45
Thank you Johnatan,
I solved my problem.
Permissions was set correctly, but problem was virtual machine ubuntu,
which didn't recognize USRP board when it was connected.
Thanks a lot.
Teodora
This topic is locked and can not be replied to.