Forum: Ruby on Rails linux and file permissions - newb linux user

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Adam A. (Guest)
on 2009-05-14 14:14
Hi Ive been googling around but cant get anything concrete on this.

Whenever I create a rails project or use a generate command I have to
use use the sudo command otherwise ubuntu complains about permissions.
However when I try to save some changes made to the files generated with
sudo in my editor (komodo) it complains i dont have permissino because
only the root has the permission to do so.

Ive read about chmod but im wondering is using it on the whole rails
project directory a smart thing to allow a user to make changes to

is there a one off command that i can use after creating the rails
project that will set this up safely for me?
Colin L. (Guest)
on 2009-05-14 15:47
(Received via mailing list)
Are you running it from your home folder (or subfolder) or somewhere

If you are running it from there which files is it complaining about
creating a project?


2009/5/14 Adam A. <removed_email_address@domain.invalid>
Adam A. (Guest)
on 2009-05-14 17:09
i dont know why but when i tried rails testproject without sudo it
worked fine... need to stop smoking crack guess.

Well now ive worked quite a bit on this sudo project so is there any way
to unsudo it quickly?

im guessing one way would be to send it to git and then grab it again
(ive never used git but someone once mentioned this in antoher thread i

but that means i nee to spend more time learning something new so if
theres another way im all ears.

many thanks for your reply!
Andrew P. (Guest)
on 2009-05-14 18:46
(Received via mailing list)
Adam A. wrote:
> Well now ive worked quite a bit on this sudo project so is there any way
> to unsudo it quickly?

cd projectdir
sudo chown -R adam .
Adam A. (Guest)
on 2009-05-15 02:09
thanks andrew for that.
This topic is locked and can not be replied to.