Forum: Ruby on Rails RJS Error: TypeError: while using active scaffold

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Chirag S. (Guest)
on 2009-05-12 14:22
Hi,

I get an unexpected error because i havent do any chnages in any
javascript files, after installing active scaffold. Before 1-2 days my
application is working fine but from yesterday i got the error for RJS
as below while i tried for show action.

RJS error:
TypeError: $("#console__private_messages-messages") is null

$("#console__private_messages-messages").html("\n  \n\n  \n\n  \n\n");

And while i tried to remove the record then i got error as per below..


RJS error:
TypeError: $("#console__complaints-list-27-row") is null


$('console__complaints-destroy-27-link').action_link.close_previous_adapter();
$("#console__complaints-list-27-row").remove();
ActiveScaffold.reload_if_empty('console__complaints-tbody','/console/complaints/update_table?page=1');
ActiveScaffold.stripe('console__complaints-tbody');
ActiveScaffold.decrement_record_count('console__complaints-active-scaffold');
$("#console__complaints-messages").html("\n  \n\n  \n\n  \n\n");

There is no errors in the log.  Any Suggestions?
Need more info?

Thanks,
Chirag Shah
Software Engineer
http://blogofchirag.blogspot.com/
This topic is locked and can not be replied to.