Forum: Ruby on Rails Flash Filereference and Rails - getting http 422

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
on 2009-05-07 04:19
(Received via mailing list)
I've spent the last few days trying to figure this out. I have my own
Filereference class I use with PHP. But I'm trying to use it with
Rails and can't seem to get it to work. I even downloaded some samples
online and can't get those to work (

Basically my rails is something like this:

    data = params[:filedata]
    name = params[:Filename]

    directory = "public/data"

      path = File.join(directory, name), 'wb') do |file|

And when I use filereference and upload it in flash I get an
httpError: 422
I get this both in mine and the example's file.
on 2009-05-08 20:00
(Received via mailing list)
Anyone know what the answer might be? Or an up to date link that
on 2009-05-08 22:53
(Received via mailing list)
Hmm. I think it may be something with the Authenticity Token. I think
I need to bypass it...
on 2009-05-09 03:06
(Received via mailing list)
K I figured out how to fetch and send the AuthToken.. It's still now

Anyone have any idea, or a resource for Flash file uploading to Rails
on 2009-05-09 05:03
(Received via mailing list)
oops, I meant still NOT working**

Any ideas?
Matt J. (Guest)
on 2009-05-09 20:03
(Received via mailing list)
Have you tried the "Flash 8 for Windows" fix on the blog page you
linked? Without any more details about your environment, that's the
first thing I'd suspect. Not sure how that fix will interact with the
new Rack stuff in 2.3, though.

--Matt J.
on 2009-05-09 22:16
(Received via mailing list)
I didn't, but I'm running on a Mac, so I figured it wouldn't matter..
Plus that post is 3 years old!
This topic is locked and can not be replied to.