Forum: RSpec cucumber segfaults

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Matthew Van Horn (Guest)
on 2009-05-06 17:59
(Received via mailing list)
Just started getting this, every time I run rake features:

rack/lint.rb:16: [BUG] Segmentation fault
ruby 1.8.6 (2008-03-03) [i686-darwin9.2.2]

after updating from cucumber 0.3.0 to 0.3.2 I'm now getting the
segfault here:

[BUG] Segmentation fault
ruby 1.8.6 (2008-03-03) [i686-darwin9.2.2]

While trying to ascertain a cause, I discovered something weird.
It seems to be related to the number of scenarios I'm running.
I had 11 scenarios, and I was getting the error every time.
I tried to isolate a cause, but the bug would not happen for any
individual scenario. I thought maybe there's some combination effect,
so I started grouping them.
I can get the error to happen about 50% of the time if I have 3 or 4
scenarios (10-12 steps)
It happens 100% of the time with more than 6 scenarios.
It happens 0% with any of the individual scenarios.

any ideas how to debug this?
This topic is locked and can not be replied to.