Forum: Ruby on Rails Trouble deploying with cap, nginx, thin, git

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cisco R. (Guest)
on 2009-05-03 10:04
I've been following along with these Slicehost tutorials on deploying a
Rails app:
http://articles.slicehost.com/2009/2/20/ubuntu-int...
http://articles.slicehost.com/2009/3/13/ubuntu-int...

but have also used Thin and Capistrano and am having a real tough time.

I've managed to get the files from my local computer up on the slice
with Capistrano, but when I run "sudo /etc/init.d/thin start" and check
out the domain all I get is "502 Bad Gateway nginx/0.6.32".  Then when I
run "sudo /etc/init.d/thin stop" I get these errors:

"[stop] /etc/thin/linksyncer.yml ...
Stopping server on 0.0.0.0:3000 ...
Can't stop process, no PID found in tmp/pids/thin.3000.pid
Stopping server on 0.0.0.0:3001 ...
Can't stop process, no PID found in tmp/pids/thin.3001.pid
Stopping server on 0.0.0.0:3002 ...
Can't stop process, no PID found in tmp/pids/thin.3002.pid"

There also seems to be some trouble with Hpricot.  In development.log I
have this error: "  Status: 500 Internal Server Error no such file to
load -- Hpricot" even though I've run sudo gem install hpricot.

Can anyone see where I'm messing up?  Or perhaps have a link to a great
step-by-step deployment tutorial?  Thanks!
This topic is locked and can not be replied to.