Forum: GNU Radio Having trouble building grc and gr-wxgui on Jaunty....

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Rob F. (Guest)
on 2009-05-01 19:27
(Received via mailing list)
Attachment: frohro.vcf (0 Bytes)
Hi Everyone,

I'm having trouble finding all the dependencies needed to compile
gnu-radio from svn with grc which needs gr-wxgui.   I installed all the
packages  mentioned on the wiki here:

http://gnuradio.org/trac/wiki/UbuntuInstall

which are:

sudo apt-get -y install swig g++ automake1.9 libtool python2.5-dev
fftw3-dev \
libcppunit-dev libboost1.35-dev sdcc-nf libusb-dev \
libsdl1.2-dev python-wxgtk2.8 subversion guile-1.8-dev \
libqt4-dev python-numpy ccache python-opengl libgsl0-dev \
python-cheetah python-lxml doxygen qt4-dev-tools \
libqwt5-qt4-dev libqwtplot3d-qt4-dev

Here is a portion of the output from ./configure that seems pertinent.

Component gr-video-sdl passed configuration checks; building.
checking for Python wxWidgets wrappers >= 2.8... no
checking for Numeric Python extensions... yes
Not building component gr-wxgui.

Any tips?

Thanks,

Rob
Josh B. (Guest)
on 2009-05-01 20:26
(Received via mailing list)
make sure python-wxgtk2.6 is removed from your system
Rob F. (Guest)
on 2009-05-02 05:29
(Received via mailing list)
Attachment: frohro.vcf (0 Bytes)
Thanks Josh,

Your nailed the problem.  I wish the automake system was smart enough to
know which version to use, but I guess not.  I think the stuff that had
to be un-installed won't be missed too badly.

73,

Rob, KL7NA
This topic is locked and can not be replied to.