Forum: Ruby on Rails Cannot get jquery to work

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Anil (Guest)
on 2009-04-30 11:12
(Received via mailing list)
<%= javascript_include_tag "jquery.js" %>

I want to add class to table tag using following command  inside
script tag.
(document).ready( function() {
             alert("abc');                                           //
for debugging


CSS has all the tree class declared
.odd {
 background-color: #fcc;

.even {
 background-color: #cef;

.table-heading {
 font-size: 12px;

CSS is linked properly and if I add class manually I can see the
stylesheet applied to the page.

But I cannot get the alert neither I can see the class in <tr> tag.

I am a newbie to rails.
any help is appreciated.

Thanks in  advance
Hassan S. (Guest)
on 2009-04-30 18:16
(Received via mailing list)
On Wed, Apr 29, 2009 at 11:39 PM, Anil <removed_email_address@domain.invalid> 
> <%= javascript_include_tag "jquery.js" %>

Shouldn't that be     <%= javascript_include_tag 'jquery' %>

You could probably easily discover whether your jquery file is being
loaded by using Firebug, btw....

Hassan S. ------------------------ removed_email_address@domain.invalid
Anil (Guest)
on 2009-04-30 20:59
(Received via mailing list)
Thanks Hassan S.,

The File is loaded correctly.
And I tried both  <%= javascript_include_tag 'jquery' %>  <%=
javascript_include_tag "jquery.js" %>
And both load the file correctly.

Moreover I can see the JavaScript (JQuery.js) loaded using firebug.

Still No luck.


On Apr 30, 7:14 am, Hassan S. <removed_email_address@domain.invalid>
Hassan S. (Guest)
on 2009-04-30 21:12
(Received via mailing list)
On Thu, Apr 30, 2009 at 9:58 AM, Anil <removed_email_address@domain.invalid> 

Oh, wait --

> <script>
> (document).ready( function() {


<script type="text/javascript">  // not THE problem, but invalid
$(document).ready( ...

Try that...
Hassan S. ------------------------ removed_email_address@domain.invalid
Brendon W. (Guest)
on 2009-04-30 22:14
(Received via mailing list)
Are you sure you are not including prototype.js?
pharrington (Guest)
on 2009-04-30 22:38
(Received via mailing list)
yeah, if you still have javascript_include_tag :defaults, prototype
will still get loaded

If you want to keep prototype loaded though (to take advantage of
Rails builtin AJAX functionality for example), will be of
Anil (Guest)
on 2009-05-01 08:03
(Received via mailing list)
The problem was the case of addClass.
Changing addclass to addClass did the trick.
Thank you very much guys for all your help.

This topic is locked and can not be replied to.