Forum: Ruby Released 1.0.0 yoda

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ryan D. (Guest)
on 2009-04-23 08:32
(Received via mailing list)
released yoda version 1.0.0 has been!

* <http://rubyforge.org/seattlerb>

Spec yoda will, and spec you shall too.

   require 'yoda'

   class Bowling
     def hit(pins)
     end

     def score
       0
     end
   end

   Bowling.yoda {
     "score 0 for gutter game".it_will {
       bowling = Bowling.new
       20.times { bowling.hit(0) }

       bowling.score 1.it_is?
       bowling.score 42.it_is_not!
     }
   }

Changes:

### 1.0.0 / 2009-04-22

* 1 major enhancement

   * Birthday!

* <http://rubyforge.org/seattlerb>
Aaron P. (Guest)
on 2009-04-23 08:35
(Received via mailing list)
On Thu, Apr 23, 2009 at 01:31:37PM +0900, Ryan D. wrote:
>
> released yoda version 1.0.0 has been!

I tried to install, and I get this error:

  [aaron@Jordan ~]$ gem install yoda
  ERROR:  gem could not be found, all around you it is.
  [aaron@Jordan ~]$ gem -v
  1.3.1
  [aaron@Jordan ~]$

Do I need rubygems 1.3.2?
Eric H. (Guest)
on 2009-04-23 10:30
(Received via mailing list)
On Apr 22, 2009, at 21:34, Aaron P. wrote:
>  [aaron@Jordan ~]$
>
> Do I need rubygems 1.3.2?


I guess so:

$ sudo gem install yoda
yoda-1.0.0 installed successfully it is
Gems installed are 1
yoda-1.0.0 ri documentation it is installing...
yoda-1.0.0 RDoc documentation it is installing...
$ gem -v
1.3.2
This topic is locked and can not be replied to.