Forum: Ruby problem with Nokogiri::HTML::Element#line

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
malikb (Guest)
on 2009-04-22 16:50
(Received via mailing list)
Hello,

I have a problem with Nokogiri::HTML::Element#line, it always returns
zero(0):

html = Nokogiri::HTML(<<eohtml)
<html>
  <head>
    <title>test test</title>
  </head>
  <body>
    Hello, world!
  </body>
</html>
eohtml

html.xpath("/html/head/title")[0].line # 0
html.xpath("/html/body")[0].line # 0

if I replace Nokogiri::HTML with Nokogiri::XML, all going to be
perfect.

Nokogiri::HTML::Element extends Nokogiri::XML::Node, so, #line should
return the line of the HTML node, isn't it?
Aaron P. (Guest)
on 2009-04-22 21:49
(Received via mailing list)
On Wed, Apr 22, 2009 at 09:50:04PM +0900, malikb wrote:
>   <body>
>
> Nokogiri::HTML::Element extends Nokogiri::XML::Node, so, #line should
> return the line of the HTML node, isn't it?

It *should* return the line.  This is most likely a bug in libxml2.
Please file a ticket here:

  http://github.com/tenderlove/nokogiri/issues

I will look in to the problem.
Aaron P. (Guest)
on 2009-04-22 21:57
(Received via mailing list)
On Wed, Apr 22, 2009 at 10:49:07AM -0700, Aaron P. wrote:
> >   </head>
> > perfect.
> >
> > Nokogiri::HTML::Element extends Nokogiri::XML::Node, so, #line should
> > return the line of the HTML node, isn't it?
>
> It *should* return the line.  This is most likely a bug in libxml2.
> Please file a ticket here:
>
>   http://github.com/tenderlove/nokogiri/issues
>
> I will look in to the problem.

Also, make sure to include the version of libxml2 you're using.  Just
print Nokogiri::LIBXML_VERSION.
This topic is locked and can not be replied to.