Forum: Ruby on Rails Nested params issue with Rack 1.0 / Unable to freeze Rails

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Olaf S. (Guest)
on 2009-04-20 23:23

I have a very strange issue. I upgraded my Application to Rails 2.3.2
without any problems, then freezed it to vendor/rails and worked through
all my specs after I also upgraded Rspec to 1.2.4. At some point (I
cannot exactly tell you when) nested parameters didn't work anymore.

That means the server receives something like:

{ "post[body]" => "data" }

instead of

{ "post" => { "body" => "data" } }

This issue seems to be known as the Rails 2.3.2 / confusion.

So I worked through all the forums, deinstalled the gem rack-0.9.1 and
checked that I have the commit 39ff550fa88da9a22d8c21ca872f5e4d0d83f8d4
That means the bundled rack-1.0 should be loaded, at least my rack.rb
reads on line 6


Still the problem persists and I don't know exactly how to fix this.

I also tried

$ sudo rake rails:freeze:edge RELEASE=

But all I get is:

cd vendor Downloading Rails from
rake aborted! Operation timed out - connect(2)

I cannot call or reach , not even in my
browser. Any ideas?

Here are two related lighthouse tickets which didn't solve my problem:

Thank you for any hints / ideas / solutions!
Olaf S. (Guest)
on 2009-04-21 01:10

$ sudo rake rails:freeze:edge RELEASE=

worked now, but the problem still persist. All my forms are broken.

Any ideas?
This topic is locked and can not be replied to.