Forum: Ruby on Rails JRuby/glassfish v3 logging problem

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Petr J. (Guest)
on 2009-04-20 08:01
Hi all,

Ive just tried to run my app with jruby and glassfish. It seems to work
mostly fine, except one weird thing. Glassfish turns over
log/development.log when its size hits 1.9MB, renames it to something


but never creates a fresh development.log and at that moment the
glassfish server just stops working.

What im doing is basically cd into my application's RAILS_ROOT, and
execute glassfish_rails.

My OS is FreeBSD 7.2

Any ideas?
Joe Athman (Guest)
on 2009-05-03 00:15
(Received via mailing list)
I have the exact same problem.  Has anyone figured out why this is?


On Apr 19, 11:01 pm, Petr J. <removed_email_address@domain.invalid>
Julian L. (Guest)
on 2009-05-03 14:14
(Received via mailing list)
Vivek P. (Guest)
on 2009-05-05 19:46
(Received via mailing list)
There are some known issues with logging, [1] and [2]. These issues are
being worked on and will be available in the next gem version (in couple
weeks). Apparently [1] is the cause of what you are experiencing related
rotation of log files.

Since rotation is not working so you as well disable it. Do the
following to
turn it off:

The setting for the log rotation is in domain.xml file. You can edit

<log-service file="${jruby.log.location}"

Set log-roation-limit-in-bytes to 0 to disable the rotation.


This topic is locked and can not be replied to.