Forum: Ruby on Rails uninitialized constant ActiveSupport::Dependencies::Mutex (NameError)

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Marc B. (Guest)
on 2009-04-16 03:12
(Received via mailing list)
I'm on debian etch w/ ruby1.8, activesupport-2.3.2, getting this on the
first line of code which is require 'active_support' :
uninitialized constant ActiveSupport::Dependencies::Mutex (NameError)
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:33:in
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:33:in `require'

Note that this worked as expected on ubuntu (ibix, amd64).


ray (Guest)
on 2009-04-17 02:38
(Received via mailing list)
I had the same issue after upgrading rails to 2.3.2 on a Debian
machine.  Updating the rubygems package (apt-get install rubygems)
fixed it.
This topic is locked and can not be replied to.