Forum: GNU Radio Some Questions about UCLA_ZIGBEE_PHY project codes

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
lizhao you (Guest)
on 2009-04-14 18:20
(Received via mailing list)
Hi all,

I am a newbie at GNU Radio, and I am in the beginning of my bachelor's
thesis, which is to connect GNU Radio with Telosb sensor node. I know
there
is a project named UCLA_ZIGBEE_PHY to connect GNU Radio with Zigbee, so
i
try to use this code to do some implementation.

Currently i use XCVR2450 Rx daugtherbroad in USRP. I installed a simple
application in telosb, and when i type the command: python
cc2420_rxtest.py
-c 2480000000(Telosb uses channel 26, and it's central frequency is
2.48G).
I get the following result:
     cordic_freq = 2.48G
     data_rate =  2M
     samples_per_symbol =  2
     usrp_decim =  16
     fs =  4M
    Using RX d'board A: XCVR2450 Rx
     >>> gr_fir_fff: using SSE
     802_15_4_pkt: waiting for packet

There's nothing more to display. So i was wondering whether GNU Radio
can
communicate with Telosb?

I check some file in UCLA_ZIGBEE_PHY project, and in
ucla_ieee802_15_4_packet_sink.h:
    static const int MSG_LEN_POS   = 8+1;         // 8 byte sos header,
1
byte AM type
    static const int MAX_PKT_LEN    = 128 - MSG_LEN_POS - 1; // remove
header and CRC
I don't think this definiton is compatible with ieee802.15.4 frame
format,
whose FCF is 2Bytes. Maybe the different frame format definition is the
problem. I am not sure.

Is there any guideline available to get GNU Radio communicated with
Telosb?
Any help is appreciated!

Thank you very much!

Regards,
You L.
gui g. (Guest)
on 2011-04-02 15:38
hi,
   Did you solve this problem?I installed both of Gnuradio and UCLA
Zigbee on ubuntu 9.10, and I have this problem´╝îcan you tell me your
ideas and experience it?

Thank you
e-mial:removed_email_address@domain.invalid
This topic is locked and can not be replied to.