Forum: Ruby on Rails My sql error: Lock wait timeout

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Sriram V. (Guest)
on 2009-04-14 11:33

I have this application where there are 5 tables.

I have the :dependent => :destroy clause  in such a way that if an entry
in the first table is deleted all the "dependent" entries in the next 4
tables are also destroyed.

The issue is there are thousands of entries in the tables and this is
taking a lot of time and I get a mysql error:

Mysql::Error: Lock wait timeout exceeded; try restarting transaction

Because of this I am not able to destroy an entry.

I tried increasing the lock wait timeout time in the mysql configuration
file. But still no improvement.

Any help would be appreciated.

Brendon W. (Guest)
on 2009-04-14 18:39
(Received via mailing list)
Do you have the correct indexes set on the tables?  It sounds like you
need to make the the delete operation far faster.

On Apr 14, 12:33 am, Sriram V. <removed_email_address@domain.invalid>
This topic is locked and can not be replied to.