Forum: Ruby on Rails uninitialized constant ActionView::Helpers::AssetTagHelper

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
johnrails (Guest)
on 2009-04-09 06:27
(Received via mailing list)
Hi All,

I just wiped out my hard drive, did a fresh install of os x 10.5, and
upgraded to rails 2.3.2. i installed the mysql pkg for os x, and
created the databases i needed for the project i was working on before
the upgrade.

However when i run rake db:migrate to run my migrations i get this
error

uninitialized constant ActionView::Helpers::AssetTagHelper

I've found some stuff about the AssetTagHelper, but i haven't found
anything related to this error when running the rake db:migrate.

Does anyone have any idea what could be going on, or link me in the
right direction?

Thanks,
John
johnrails (Guest)
on 2009-04-10 07:28
(Received via mailing list)
I've made some progress since this post. I've installed ruby and
rubygems from source, and now when i run rake i get this error:

Rails requires RubyGems >= 0.9.4 (you have ). Please `gem update --
system` and try again.

For some reason boot.rb can't find which version of rubygems i have
installed, but i have 1.3.1 installed.

Has anyone else experienced this?

Thanks,
John
Wisccal W. (Guest)
on 2009-04-13 19:38
johnrails wrote:
> I've made some progress since this post. I've installed ruby and
> rubygems from source, and now when i run rake i get this error:
>
> Rails requires RubyGems >= 0.9.4 (you have ). Please `gem update --
> system` and try again.
>
> For some reason boot.rb can't find which version of rubygems i have
> installed, but i have 1.3.1 installed.
>
> Has anyone else experienced this?
>
> Thanks,
> John

It sounds like you have two gem versions in your path. What does the
output of "gem env" give you?
Rodrigo R. (Guest)
on 2009-05-16 21:29
Wisccal W. wrote:
> johnrails wrote:
>> I've made some progress since this post. I've installed ruby and
>> rubygems from source, and now when i run rake i get this error:
>>
>> Rails requires RubyGems >= 0.9.4 (you have ). Please `gem update --
>> system` and try again.
>>
>> For some reason boot.rb can't find which version of rubygems i have
>> installed, but i have 1.3.1 installed.
>>
>> Has anyone else experienced this?
>>
>> Thanks,
>> John
>
> It sounds like you have two gem versions in your path. What does the
> output of "gem env" give you?

I have the same problem you describe, and it has nothing to do with
rubygems, in fact the problem is related to a rails plugin called
app_config. I am still trying to patch the problem with rails 2.3.2, but
for now you can try just to uninstall that plugin.
Rodrigo R. (Guest)
on 2009-05-17 02:20
Sorry, that was not the cause of the error, it was overriding some Date
and DateHelper methods to translate months and days.
This topic is locked and can not be replied to.