Forum: Ruby rubygem 1.3.1: zlib LoadError

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Kinroc C. (Guest)
on 2009-04-07 05:22
why am i getting this zlib error?

RUBYGEMS VERSION: 1.3.1
RUBY VERSION: 1.9.1 (2009-01-30 patchlevel 0) [i686-linux]

/opt/ruby/bin$ gem list
/opt/ruby/lib/ruby/1.9.1/rubygems/spec_fetcher.rb:1:in `require': no
such file to load -- zlib (LoadError)
        from /opt/ruby/lib/ruby/1.9.1/rubygems/spec_fetcher.rb:1:in
`<top (required)>'
        from
/opt/ruby/lib/ruby/1.9.1/rubygems/commands/query_command.rb:3:in
`require'
        from
/opt/ruby/lib/ruby/1.9.1/rubygems/commands/query_command.rb:3:in `<top
(required)>'
        from
/opt/ruby/lib/ruby/1.9.1/rubygems/commands/list_command.rb:2:in
`require'
        from
/opt/ruby/lib/ruby/1.9.1/rubygems/commands/list_command.rb:2:in `<top
(required)>'
        from /opt/ruby/lib/ruby/1.9.1/rubygems/command_manager.rb:140:in
`require'
        from /opt/ruby/lib/ruby/1.9.1/rubygems/command_manager.rb:140:in
`rescue in load_and_instantiate'
        from /opt/ruby/lib/ruby/1.9.1/rubygems/command_manager.rb:132:in
`load_and_instantiate'
        from /opt/ruby/lib/ruby/1.9.1/rubygems/command_manager.rb:65:in
`[]'
        from /opt/ruby/lib/ruby/1.9.1/rubygems/command_manager.rb:118:in
`find_command'
        from /opt/ruby/lib/ruby/1.9.1/rubygems/command_manager.rb:104:in
`process_args'
        from /opt/ruby/lib/ruby/1.9.1/rubygems/command_manager.rb:75:in
`run'
        from /opt/ruby/lib/ruby/1.9.1/rubygems/gem_runner.rb:39:in `run'
        from /opt/ruby/bin/gem:24:in `<main>'
Matt Falkenhagen (Guest)
on 2009-04-07 05:26
(Received via mailing list)
Kinroc Cornik wrote:
> why am i getting this zlib error?
>
> RUBYGEMS VERSION: 1.3.1
> RUBY VERSION: 1.9.1 (2009-01-30 patchlevel 0) [i686-linux]
>
> /opt/ruby/bin$ gem list
> /opt/ruby/lib/ruby/1.9.1/rubygems/spec_fetcher.rb:1:in `require': no
> such file to load -- zlib (LoadError)

You probably don't have the zlib development library installed.  Ensure
both the runtime and development library are installed.
Jun Y. Kim (Guest)
on 2009-04-07 06:06
(Received via mailing list)
this problems also happen in hpux(11.23, 11.31).

ruby installer doesn't distinguish between sl and so extension.

I need to make all symbolic links from sl to so in /usr/local/lib/ruby/*

2009. 04. 07, ¿ÀÀü 10:24, Matt Falkenhagen ÀÛ¼º:
This topic is locked and can not be replied to.